Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Error: argv0 not available
From: Austin Baker (asb93_at_[hidden])
Date: 2012-09-01 13:10:17


I have the most current version installed. I tried that first.

Austin Baker
asb93_at_[hidden]
Graduate Student
Department of Chemistry
University of Pittsburgh

Everything is Experimental

On Sep 1, 2012, at 12:41 PM, Jeff Squyres (jsquyres) wrote:

> The root cause is that you didn't specify an executable to run.
>
> However, we might have some help messages missing, too. What version of OMPI are you running?
>
> Sent from my phone. No type good.
>
> On Sep 1, 2012, at 12:22 PM, "Austin Baker" <asb93_at_[hidden]> wrote:
>
>> All,
>>
>> I am quite new to using Open MPI as it is required by programs that I use for research. While running a chemistry program through Terminal, I inadvertently hit enter after I tried to run the program over multiple processors and am now getting one of two errors when I try and run the programs that I need. I've seen a couple of help topics that are along the same lines, but I can't seem to find an actual solution.
>>
>> When I just ran the MPI this is the error I got
>> Austins-iMac:man1 ABProds$ /Applications/OpenEye/arch/osx-10.7-x64/oedocking/3.0.0/mpi/bin/mpirun -np 3
>> --------------------------------------------------------------------------
>> Sorry! You were supposed to get help about:
>> orterun:executable-not-specified
>> from the file:
>> help-orterun.txt
>> But I couldn't find any file matching that name. Sorry!
>>
>> When I try and run other programs that I need this is the error:
>> Austins-iMac:man1 ABProds$ /Applications/OpenEye/arch/osx-10.7-x64/oedocking/3.0.0/mpi/bin/mpirun -np 3 /Applications/arch/osx-10.7-x64/oedocking/3.0.0/fred -receptor ~/Documents/Research2012/FredData/Fyn_TargetSite.oeb -dbase ~/Documents/Research2012/FredData/Zinc1/TopScores/zinc_57078852.mo;2 -numposes 1500
>> --------------------------------------------------------------------------
>> Sorry! You were supposed to get help about:
>> argv0-not-accessible
>> from the file:
>> help-rmgr-base.txt
>> But I couldn't find any file matching that name. Sorry!
>>
>>
>> Very much appreciated for the help
>>
>>
>> Austin Baker
>> asb93_at_[hidden]
>> Graduate Student
>> Department of Chemistry
>> University of Pittsburgh
>>
>> Everything is Experimental
>>
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users