Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] what is a "node"?
From: Ralph Castain (rhc_at_[hidden])
Date: 2012-09-01 06:55:22


You are using cmd line options that no longer exist in the 1.9 release - look at "mpirun -h" for the current list of options.

FWIW: in your example, the correct cmd line would be:

mpirun -np 2 --bind-to core -map-by core --report-bindings uptime

Note the space in "--bind-to core" and the "-map-by" option syntax. The warning means that we didn't find libnuma installed on your machine, so we cannot bind memory allocations (but can bind processes).

On Sep 1, 2012, at 3:41 AM, Zbigniew Koza <zzkoza_at_[hidden]> wrote:

> Hi,
>
> I have one more question.
> I wanted to experiment with processor affinity command-line options on my ubuntu PC.
> When I use OpenMPI compiled from sourecs a few weeks ago, mpirun returns error messages.
> However, the"official" OpenMPI installation on the same machine makes no problem.
> Does it mean there's a bug in OpenMPI-current and I should report a bug?
>
> ======= 1. OpneMPI version: ====
>
> mpirun -V
> mpirun (Open MPI) 1.9a1r26880
>
> Report bugs to http://www.open-mpi.org/community/help/
>
>
> ==== 2. mpirun "offending" command and error report: ===
>
> zkoza_at_zbyszek:~$ mpirun -np 2 --bind-to-core -bycore --report-bindings uptime
> --------------------------------------------------------------------------
> WARNING: a request was made to bind a process. While the system
> supports binding the process itself, at least one node does NOT
> support binding memory to the process location.
>
> Node: zbyszek
>
> This is a warning only; your job will continue, though performance may
> be degraded.
> --------------------------------------------------------------------------
> --------------------------------------------------------------------------
> mpirun was unable to find the specified executable file, and therefore
> did not launch the job. This error was first reported for process
> rank 0; it may have occurred for other processes as well.
>
> NOTE: A common cause for this error is misspelling a mpirun command
> line parameter option (remember that mpirun interprets the first
> unrecognized command line token as the executable).
>
> Node: zbyszek
> Executable: -bycore
> --------------------------------------------------------------------------
> 2 total processes failed to start
>
>
> ==== 3. the same mpirun command using standard MPI installation ====
>
> LD_LIBRARY_PATH=/usr/lib/openmpi /usr/bin/mpirun --path /usr/lib/openmpi -np 2 --bind-to-core -bycore --report-bindings uptime
> [zbyszek:03104] [[7637,0],0] odls:default:fork binding child [[7637,1],0] to cpus 0001
> [zbyszek:03104] [[7637,0],0] odls:default:fork binding child [[7637,1],1] to cpus 0002
> 12:25:51 up 21:27, 1 user, load average: 0.00, 0.01, 0.05
> 12:25:51 up 21:27, 1 user, load average: 0.00, 0.01, 0.05
>
>
> ==== 4. version of standard OpenMPI ===
>
> zkoza_at_zbyszek:~$ LD_LIBRARY_PATH=/usr/lib/openmpi /usr/bin/mpirun --path /usr/lib/openmpi --version
> mpirun (Open MPI) 1.4.3
>
>
>
> Z Koza
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users