Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] error compiling openmpi-1.6.1 on Windows 7
From: Siegmar Gross (Siegmar.Gross_at_[hidden])
Date: 2012-08-30 08:05:58


Hi Shiqing,

> Could you please send the output of ompi_info command under you 64 bit
> env? And could you please also check if you have CCP or HPC pack
> installed? The incorrect configuration of that might cause Open MPI hanging.

I haven't installed Microsoft's Compute Cluster Pack or High Performance
Computing Pack. At the moment I'm testing Open MPI on my Acer notebook
with Windows 7 Professional SP1. "ompi_info" hangs as well before it
prints any information about mca modules.

C:\Program Files\openmpi-1.6.1\bin>ompi_info
                 Package: Open MPI Admin_at_HERMES Distribution
                Open MPI: 1.6.1
   Open MPI SVN revision: r27106
   Open MPI release date: Aug 22, 2012
                Open RTE: 1.6.1
   Open RTE SVN revision: r27106
   Open RTE release date: Aug 22, 2012
                    OPAL: 1.6.1
       OPAL SVN revision: r27106
       OPAL release date: Aug 22, 2012
                 MPI API: 2.1
            Ident string: 1.6.1
                  Prefix: C:\Program Files\openmpi-1.6.1\bin/..
 Configured architecture: Windows-6.1 64 bit
          Configure host: HERMES
           Configured by: Admin
           Configured on: 14:40 27.08.2012
          Configure host: HERMES
                Built by: Admin
                Built on: 14:40 27.08.2012
              Built host: HERMES
              C bindings: yes
            C++ bindings: yes
      Fortran77 bindings: no
      Fortran90 bindings: no
 Fortran90 bindings size: na
              C compiler: cl
     C compiler absolute: cl
  C compiler family name: MICROSOFT
      C compiler version: 1600
            C++ compiler: cl
   C++ compiler absolute: cl
      Fortran77 compiler: none
  Fortran77 compiler abs: none
      Fortran90 compiler: none
  Fortran90 compiler abs: none
             C profiling: yes
           C++ profiling: yes
     Fortran77 profiling: no
     Fortran90 profiling: no
          C++ exceptions: no
          Thread support: no
           Sparse Groups: no
  Internal debug support: no
  MPI interface warnings: no
     MPI parameter check: never
Memory profiling support: no
Memory debugging support: no
         libltdl support: no
   Heterogeneous support: yes
 mpirun default --prefix: yes
         MPI I/O support: yes
       MPI_WTIME support: gettimeofday
     Symbol vis. support: yes
   Host topology support: no
          MPI extensions: none
   FT Checkpoint support: yes (checkpoint thread: no)
     VampirTrace support: no
  MPI_MAX_PROCESSOR_NAME: 256
    MPI_MAX_ERROR_STRING: 256
     MPI_MAX_OBJECT_NAME: 64
        MPI_MAX_INFO_KEY: 36
        MPI_MAX_INFO_VAL: 256
       MPI_MAX_PORT_NAME: 1024
  MPI_MAX_DATAREP_STRING: 128

Kind regards

Siegmar

> On 2012-08-29 12:33 PM, Siegmar Gross wrote:
> > Hi Shiqing,
> >
> >> It seems that the runtime environment is messed up with the different
> >> versions of Open MPI. I suggest you completely remove all the
> >> installations and install 1.6.1 again (just build the installation
> >> project again). It should work without any problem under Cygwin too.
> > I removed openmpi-1.6 und rebuilt openmpi-1.6.1. Now I can compile and
> > run a program in 32-bit mode but have still some problems.
> >
> > D:\...\prog\mpi\small_prog>mpicc init_finalize.c
> > Microsoft (R) 32-Bit C/C++-Optimierungscompiler Version
> > 16.00.40219.01 für 80x86
> > Copyright (C) Microsoft Corporation. Alle Rechte vorbehalten.
> >
> > init_finalize.c
> > Microsoft (R) Incremental Linker Version 10.00.40219.01
> > Copyright (C) Microsoft Corporation. All rights reserved.
> >
> > /out:init_finalize.exe
> > "/LIBPATH:C:\Program Files (x86)\openmpi-1.6.1\bin/../lib"
> > libmpi.lib
> > libopen-pal.lib
> > libopen-rte.lib
> > advapi32.lib
> > Ws2_32.lib
> > shlwapi.lib
> > init_finalize.obj
> >
> > D:\...\prog\mpi\small_prog>mpiexec init_finalize.exe
> > ---------------------------------------------------------------------
> > Sorry! You were supposed to get help about:
> > invalid if_inexclude
> > But I couldn't open the help file:
> > D:\...\prog\mpi\small_prog\..\share\openmpi\help-mpi-btl-tcp.txt:
> > No such file or directory. Sorry!
> > ---------------------------------------------------------------------
> >
> > Hello!
> >
> >
> > Why does "mpiexec" look for the help file relativ to my current
> > program and not relative to itself? The file is part of the
> > package.
> >
> > dir "c:\Program Files
(x86)\openmpi-1.6.1\share\openmpi\help-mpi-btl-tcp.txt"
> > ...
> > 03.04.2012 16:30 631 help-mpi-btl-tcp.txt
> >
> > Must I change something in the source code or can I set an environment
> > variable for help files? Why does "mpiexec" want to give some help at all?
> > I don't get this message for openmpi-1.5.1.
> >
> >
> > D:\...\prog\mpi\small_prog>mpicc init_finalize.c
> > Microsoft (R) 32-Bit C/C++-Optimierungscompiler Version 16.00.40219.01
> > für 80x86
> > Copyright (C) Microsoft Corporation. Alle Rechte vorbehalten.
> >
> > init_finalize.c
> > Microsoft (R) Incremental Linker Version 10.00.40219.01
> > Copyright (C) Microsoft Corporation. All rights reserved.
> >
> > /out:init_finalize.exe
> > "/LIBPATH:C:/Program Files (x86)/openmpi-1.5.1/lib"
> > libmpi.lib
> > libopen-pal.lib
> > libopen-rte.lib
> > advapi32.lib
> > Ws2_32.lib
> > shlwapi.lib
> > init_finalize.obj
> >
> > D:\...\prog\mpi\small_prog>mpiexec init_finalize.exe
> > Hello!
> > D:\...\prog\mpi\small_prog>
> >
> >
> >
> >
> >
> > I can also compile in 64-bit mode but the program hangs.
> >
> >
> > D:\...\prog\mpi\small_prog>mpicc init_finalize.c
> >
> > Microsoft (R) C/C++-Optimierungscompiler Version 16.00.40219.01 für x64
> > Copyright (C) Microsoft Corporation. Alle Rechte vorbehalten.
> >
> > init_finalize.c
> > Microsoft (R) Incremental Linker Version 10.00.40219.01
> > Copyright (C) Microsoft Corporation. All rights reserved.
> >
> > /out:init_finalize.exe
> > "/LIBPATH:C:\Program Files\openmpi-1.6.1\bin/../lib"
> > libmpi.lib
> > libopen-pal.lib
> > libopen-rte.lib
> > advapi32.lib
> > Ws2_32.lib
> > shlwapi.lib
> > init_finalize.obj
> >
> > D:\...\prog\mpi\small_prog>mpiexec init_finalize.exe
> > ^C
> > D:\...\prog\mpi\small_prog>
> >
> >
> > It's the same if I compile a 64-bit program with openmpi-1.5.1. The program
> > itself is very small.
> >
> > #include <stdio.h>
> > #include <stdlib.h>
> > #include "mpi.h"
> >
> > int main (int argc, char *argv[])
> > {
> > MPI_Init (&argc, &argv);
> > printf ("Hello!\n");
> > MPI_Finalize ();
> > return EXIT_SUCCESS;
> > }
> >
> >
> > Any ideas why the 64-bit version hangs? Thank you very much for any help
> > in advance.
> >
> >
> > Kind regards
> >
> > Siegmar
> >
> >
> > _______________________________________________
> > users mailing list
> > users_at_[hidden]
> > http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>
> --
> ---------------------------------------------------------------
> Shiqing Fan
> High Performance Computing Center Stuttgart (HLRS)
> Tel: ++49(0)711-685-87234 Nobelstrasse 19
> Fax: ++49(0)711-685-65832 70569 Stuttgart
> http://www.hlrs.de/organization/people/shiqing-fan/
> email: fan_at_[hidden]
>