Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] deprecated MCA parameter
From: jody (jody.xha_at_[hidden])
Date: 2012-08-28 09:07:37


Hi Rallph

I get one of these messages
--------------------------------------------------------------------------
A deprecated MCA parameter value was specified in the environment or
on the command line. Deprecated MCA parameters should be avoided;
they may disappear in future releases.

  Deprecated parameter: plm_rsh_agent
--------------------------------------------------------------------------
for every process that starts...

My openmpi version is 1.6 (gentoo package sys-cluster/openmpi-1.6-r1)

jody

On Tue, Aug 28, 2012 at 2:38 PM, Ralph Castain <rhc_at_[hidden]> wrote:
> Guess I'm confused - what is the issue here? The param still exists:
>
> MCA plm: parameter "plm_rsh_agent" (current value: <ssh : rsh>, data source: default value, synonyms:
> pls_rsh_agent, orte_rsh_agent)
> The command used to launch executables on remote nodes (typically either "ssh" or "rsh")
>
> I am unaware of any plans to deprecate it. Is there a problem with it?
>
> On Aug 28, 2012, at 2:24 AM, jody <jody.xha_at_[hidden]> wrote:
>
>> Hi
>>
>> In order to open a xterm for each of my processes i use the MCA
>> parameter 'plm_rsh_agent'
>> like this:
>> mpirun -np 5 -hostfile allhosts -mca plm_base_verbose 1 -mca
>> plm_rsh_agent "ssh -Y" --leave-session-attached xterm -hold -e
>> ./MPIProg
>>
>> Without the option ' -mca plm_rsh_agent "ssh -Y"' i can't open windows
>> from the remote:
>>
>> jody_at_boss /mnt/data1/neander $ mpirun -np 5 -hostfile allhosts
>> -mca plm_base_verbose 1 --leave-session-attached xterm -hold -e
>> ./MPIStruct
>> xterm: Xt error: Can't open display:
>> xterm: DISPLAY is not set
>> xterm: Xt error: Can't open display:
>> xterm: DISPLAY is not set
>> xterm: Xt error: Can't open display:
>> xterm: DISPLAY is not set
>> xterm: Xt error: Can't open display:
>> xterm: DISPLAY is not set
>> xterm: Xt error: Can't open display:
>> xterm: DISPLAY is not set
>> --------------------------------------------------------------------------
>> mpirun noticed that the job aborted, but has no info as to the process
>> that caused that situation.
>> --------------------------------------------------------------------------
>>
>> Is there some replacement for this parameter,
>> or how else can i get mpi to use" ssh -Y for" its connections?
>>
>> Thank You
>> jody
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users