Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] ORTE_ERROR: orte_ess_base_open failed
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2012-08-27 12:29:24


Did you install Open MPI on a network share, or is it installed locally on each machine?

If you installed it locally on each machine, you may want to double check your installation on AV8 to ensure it was installed correctly.

Also, you might want to double check that Open MPI is available at the same paths on every machine one which you're trying to run (e.g., if you installed in /opt/openmpi on one machine, make sure you installed on /opt/openmpi on all machines). You don't *have* to do this -- Open MPI *can* run if it's installed in different directories on each machine -- but it's *significantly* simpler if Open MPI is installed in the same directory on each machine.

On Aug 26, 2012, at 10:59 PM, Ralph Castain wrote:

> I have no further ideas, I'm afraid. The only thing I can see is that your directory tree doesn't look right - if /usr/local is your prefix, then there should be a /usr/local/lib/openmpi directory, and the .la's should be in there.
>
> You might try reinstalling it to somewhere other than /usr/local - perhaps put it somewhere under your home directory instead so you don't need root permissions to do the install. See if the directory tree looks any different.
>
> It would also help to see your configure line, and know something more about your system. It looks like you have slurm, so I assume this is some kind of Linux box?
>
>
> On Aug 26, 2012, at 7:23 PM, Shanthini Kannan <shanthinick_at_[hidden]> wrote:
>
>> Hello Ralph,
>> /usr/local/lib is in my LD_LIBRARY_PATH.
>> I am running the right version of mpirun and I do have all permissions on them.
>>
>> Thanks!
>> Shanthini
>>
>> On Fri, Aug 24, 2012 at 7:30 PM, Ralph Castain <rhc_at_[hidden]> wrote:
>> And just to be sure - /usr/local/lib is in your ld_lib_path, yes?
>>
>> You might also check the permissions to ensure you can read them. Also, check "which mpirun" - let's make sure you are running the one you think!
>>
>> On Aug 24, 2012, at 4:22 PM, Shanthini Kannan <shanthinick_at_[hidden]> wrote:
>>
>>> Thanks Ralph.
>>> My prefix is /usr/local and I see that mca_ess_env.la is present in /usr/local/lib directory.
>>>
>>> -bash-4.2# pwd
>>> /usr/local/lib
>>> -bash-4.2# ls mca_ess*
>>> mca_ess_env.la mca_ess_singleton.la mca_ess_slurm.la mca_ess_tool.la
>>> mca_ess_env.so mca_ess_singleton.so mca_ess_slurm.so mca_ess_tool.so
>>> mca_ess_hnp.la mca_ess_slave.la mca_ess_slurmd.la
>>> mca_ess_hnp.so mca_ess_slave.so mca_ess_slurmd.so
>>> -bash-4.2#
>>>
>>> On Fri, Aug 24, 2012 at 7:13 PM, Ralph Castain <rhc_at_[hidden]> wrote:
>>> Check you <prefix>/lib directory - there should be an openmpi directory under it, and that should have a bunch of libs in it. One of those should be mca_ess_env.la
>>>
>>> Is it there?
>>>
>>> On Aug 24, 2012, at 3:27 PM, Shanthini Kannan <shanthinick_at_[hidden]> wrote:
>>>
>>>> I had the OMPI lib directory added in /etc/ld.so.conf.
>>>> I also added it in LD_LIBRARY_PATH, but it made no difference.
>>>> When I call mpirun, should I specify the MCA in command-line?
>>>> Thanks!
>>>>
>>>> On Fri, Aug 24, 2012 at 2:07 PM, Ralph Castain <rhc_at_[hidden]> wrote:
>>>> I suspect your LD_LIBRARY_PATH doesn't include the OMPI lib location
>>>>
>>>> On Aug 24, 2012, at 10:58 AM, Shanthini Kannan <shanthinick_at_[hidden]> wrote:
>>>>
>>>>> Hello,
>>>>> I am running mpptest over Open MPI (v1.5.4).
>>>>> I get the following error saying component "env" in Framework "ess" is not found. Am I missing something? I am new to MPI and any help you can offer is appreciated.
>>>>>
>>>>> A requested component was not found, or was unable to be opened. This
>>>>> means that this component is either not installed or is unable to be
>>>>> used on your system (e.g., sometimes this means that shared libraries
>>>>> that the component requires are unable to be found/loaded). Note that
>>>>> Open MPI stopped checking at the first component that it did not find.
>>>>>
>>>>> Host: AV8
>>>>> Framework: ess
>>>>> Component: env
>>>>> --------------------------------------------------------------------------
>>>>> [AV8:05354] [[INVALID],INVALID] ORTE_ERROR_LOG: Error in file runtime/orte_init.c at line 120
>>>>> --------------------------------------------------------------------------
>>>>> It looks like orte_init failed for some reason; your parallel process is
>>>>> likely to abort. There are many reasons that a parallel process can
>>>>> fail during orte_init; some of which are due to configuration or
>>>>> environment problems. This failure appears to be an internal failure;
>>>>> here's some additional information (which may only be relevant to an
>>>>> Open MPI developer):
>>>>>
>>>>> orte_ess_base_open failed
>>>>> --> Returned value Error (-1) instead of ORTE_SUCCESS
>>>>>
>>>>> Thanks!
>>>>> Shanthini
>>>>> _______________________________________________
>>>>> users mailing list
>>>>> users_at_[hidden]
>>>>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>>>
>>>>
>>>> _______________________________________________
>>>> users mailing list
>>>> users_at_[hidden]
>>>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>>>
>>>> _______________________________________________
>>>> users mailing list
>>>> users_at_[hidden]
>>>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>>
>>>
>>> _______________________________________________
>>> users mailing list
>>> users_at_[hidden]
>>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>>
>>> _______________________________________________
>>> users mailing list
>>> users_at_[hidden]
>>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>
>>
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Jeff Squyres
jsquyres_at_[hidden]
For corporate legal information go to: http://www.cisco.com/web/about/doing_business/legal/cri/