Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] ORTE_ERROR: orte_ess_base_open failed
From: Ralph Castain (rhc_at_[hidden])
Date: 2012-08-24 19:13:52


Check you <prefix>/lib directory - there should be an openmpi directory under it, and that should have a bunch of libs in it. One of those should be mca_ess_env.la

Is it there?

On Aug 24, 2012, at 3:27 PM, Shanthini Kannan <shanthinick_at_[hidden]> wrote:

> I had the OMPI lib directory added in /etc/ld.so.conf.
> I also added it in LD_LIBRARY_PATH, but it made no difference.
> When I call mpirun, should I specify the MCA in command-line?
> Thanks!
>
> On Fri, Aug 24, 2012 at 2:07 PM, Ralph Castain <rhc_at_[hidden]> wrote:
> I suspect your LD_LIBRARY_PATH doesn't include the OMPI lib location
>
> On Aug 24, 2012, at 10:58 AM, Shanthini Kannan <shanthinick_at_[hidden]> wrote:
>
>> Hello,
>> I am running mpptest over Open MPI (v1.5.4).
>> I get the following error saying component "env" in Framework "ess" is not found. Am I missing something? I am new to MPI and any help you can offer is appreciated.
>>
>> A requested component was not found, or was unable to be opened. This
>> means that this component is either not installed or is unable to be
>> used on your system (e.g., sometimes this means that shared libraries
>> that the component requires are unable to be found/loaded). Note that
>> Open MPI stopped checking at the first component that it did not find.
>>
>> Host: AV8
>> Framework: ess
>> Component: env
>> --------------------------------------------------------------------------
>> [AV8:05354] [[INVALID],INVALID] ORTE_ERROR_LOG: Error in file runtime/orte_init.c at line 120
>> --------------------------------------------------------------------------
>> It looks like orte_init failed for some reason; your parallel process is
>> likely to abort. There are many reasons that a parallel process can
>> fail during orte_init; some of which are due to configuration or
>> environment problems. This failure appears to be an internal failure;
>> here's some additional information (which may only be relevant to an
>> Open MPI developer):
>>
>> orte_ess_base_open failed
>> --> Returned value Error (-1) instead of ORTE_SUCCESS
>>
>> Thanks!
>> Shanthini
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users