Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Getting MPI to access processes on a 2nd computer.
From: VimalMathew_at_[hidden]
Date: 2012-07-05 09:58:19


Hi Shiqing,

 

We went through the steps mentioned in the links to modify DCOM and COM
settings.

wmic /node:remote_node_ip process call create notepad.exe is able to
create a notepad process remotely, but I'm getting the same error
message as before using mpirun -np 2 -host host1 host2 notepad.exe.

 

I'm running this on two Windows 7 machines both of which I have admin
rights on.

Any suggestions?

 

Thanks,

Vimal

 

From: Shiqing Fan [mailto:fan_at_[hidden]]
Sent: Wednesday, July 04, 2012 5:28 AM
To: Open MPI Users
Cc: Mathew, Vimal
Subject: Re: [OMPI users] Getting MPI to access processes on a 2nd
computer.

 

Hi,

The Open MPI potentially uses WMI to launch remote processes, so the WMI
has to be configured correctly. There are two links talking about how to
set it up in README.WINDOWS file:

http://msdn.microsoft.com/en-us/library/aa393266(VS.85).aspx
<http://msdn.microsoft.com/en-us/library/aa393266%28VS.85%29.aspx>
http://community.spiceworks.com/topic/578

For testing whether it works or not, you can use following command:
wmic /node:remote_node_ip process call create notepad.exe

then log onto the other Windows, check in the task manager if the
notepad.exe process is created (don't forget to delete it afterwards).

If that works, this command will also work:
mpirun -np 2 -host host1 host2 notepad.exe

Please try to run the above two test commands, if they all works you
application should also work. Just let me know if you have any question
or trouble with that.

Shiqing

On 2012-07-03 8:53 PM, VimalMathew_at_[hidden] wrote:

        Hi,

         

        I'm trying to run an MPI code using processes on a remote
machine.

        I've connected the 2 machines using a crossover cable and they
are communicating with each other(I'm getting ping replies and I can
access drives on one another).

         

        When I run mpiexec -host system_name MPI_Test.exe, I get the
following error:

         

        C:\OpenMPI\openmpi-1.6\build\Debug>mpiexec -host SOUMIWHP4500449
MPI_Test.exe

        connecting to SOUMIWHP4500449

        username:C9995799

        password:**********

        Save Credential?(Y/N) N

        [SOUMIWHP5003567:01728] Could not connect to namespace cimv2 on
node SOUMIWHP450

        0449. Error code =-2147023174

        
------------------------------------------------------------------------

--
	mpiexec was unable to start the specified application as it
encountered an error
	.
	More information may be available above.
	
------------------------------------------------------------------------
--
	[SOUMIWHP5003567:01728] [[38316,0],0] ORTE_ERROR_LOG: A message
is attempting to
	be sent to a process whose contact information is unknown in
file ..\..\..\open
	mpi-1.6\orte\mca\rml\oob\rml_oob_send.c at line 145
	[SOUMIWHP5003567:01728] [[38316,0],0] attempted to send to
[[38316,0],1]: tag 1
	[SOUMIWHP5003567:01728] [[38316,0],0] ORTE_ERROR_LOG: A message
is attempting to
	be sent to a process whose contact information is unknown in
file ..\..\..\open
	mpi-1.6\orte\orted\orted_comm.c at line 126
	 
	Could anyone tell me what I'm missing?
	 
	I've configured MPI on VS Express 2010 and I'm able to run MPI
programs on one system.
	On the other computer, I pasted the MPI_Test.exe file in the
same location as the calling computer.
	 
	Thanks,
	Vimal
	 
	
	
	
	
	_______________________________________________
	users mailing list
	users_at_[hidden]
	http://www.open-mpi.org/mailman/listinfo.cgi/users
-- 
---------------------------------------------------------------
Shiqing Fan
High Performance Computing Center Stuttgart (HLRS)
Tel: ++49(0)711-685-87234      Nobelstrasse 19
Fax: ++49(0)711-685-65832      70569 Stuttgart
http://www.hlrs.de/organization/people/shiqing-fan/
email: fan_at_[hidden]