Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: [OMPI users] Getting MPI to access processes on a 2nd computer.
From: VimalMathew_at_[hidden]
Date: 2012-07-03 14:53:13


Hi,

 

I'm trying to run an MPI code using processes on a remote machine.

I've connected the 2 machines using a crossover cable and they are
communicating with each other(I'm getting ping replies and I can access
drives on one another).

 

When I run mpiexec -host system_name MPI_Test.exe, I get the following
error:

 

C:\OpenMPI\openmpi-1.6\build\Debug>mpiexec -host SOUMIWHP4500449
MPI_Test.exe

connecting to SOUMIWHP4500449

username:C9995799

password:**********

Save Credential?(Y/N) N

[SOUMIWHP5003567:01728] Could not connect to namespace cimv2 on node
SOUMIWHP450

0449. Error code =-2147023174

------------------------------------------------------------------------

--
mpiexec was unable to start the specified application as it encountered
an error
.
More information may be available above.
------------------------------------------------------------------------
--
[SOUMIWHP5003567:01728] [[38316,0],0] ORTE_ERROR_LOG: A message is
attempting to
be sent to a process whose contact information is unknown in file
..\..\..\open
mpi-1.6\orte\mca\rml\oob\rml_oob_send.c at line 145
[SOUMIWHP5003567:01728] [[38316,0],0] attempted to send to
[[38316,0],1]: tag 1
[SOUMIWHP5003567:01728] [[38316,0],0] ORTE_ERROR_LOG: A message is
attempting to
be sent to a process whose contact information is unknown in file
..\..\..\open
mpi-1.6\orte\orted\orted_comm.c at line 126
 
Could anyone tell me what I'm missing?
 
I've configured MPI on VS Express 2010 and I'm able to run MPI programs
on one system.
On the other computer, I pasted the MPI_Test.exe file in the same
location as the calling computer.
 
Thanks,
Vimal