Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Myricom MX2G Segmentation fault on OMPI 1.6
From: Yong Qin (yong.qin_at_[hidden])
Date: 2012-06-29 14:24:00


I'm confused now :).

I thought that's what I did, removing "mca_btl_mx.la" and
"mca_btl_mx.so". This is the MX BTL plugin, right?

On Fri, Jun 29, 2012 at 11:16 AM, Jeff Squyres <jsquyres_at_[hidden]> wrote:
> On Jun 29, 2012, at 2:14 PM, Yong Qin wrote:
>
>> Thanks Jeff for the doc. However I'm not sure if I understand your
>> following comment correctly. If I remove the MX BTL plugins, a.k.a.,
>> mca_btl_mx.la and mca_btl_mx.so, I'm now getting errors of these
>> components not found.
>>
>> [n0026.hbar:09467] mca: base: component_find: unable to open
>> .../mca_btl_mx.la: file not found (ignored)
>> [n0026.hbar:09467] mca: base: component_find: unable to open
>> .../mca_btl_mx.so: file not found (ignored)
>>
>> And it still uses TCP BTL instead of MX MTL from what I can tell. Am I
>> doing things wrong?
>
> Yoinks, I'm sorry -- that's not quite what I meant.  I meant remove the *BTL* plugin, not the *MTL* plugin.
>
> I.e., if *only* the MX MTL is there, there should be no conflict between the two (per that bug you and George found), and you should be ok.
>
> --
> Jeff Squyres
> jsquyres_at_[hidden]
> For corporate legal information go to: http://www.cisco.com/web/about/doing_business/legal/cri/
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users