Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Building MPI on Windows
From: Damien (damien_at_[hidden])
Date: 2012-06-14 16:55:14


You did build the project, right? The helloworldMPI.exe is in the Debug
directory?

On 14/06/2012 1:49 PM, VimalMathew_at_[hidden] wrote:
>
> No luck.
>
> Output:
>
> *Microsoft Windows [Version 6.1.7601]*
>
> *Copyright (c) 2009 Microsoft Corporation. All rights reserved.*
>
> **
>
> *C:\Users\...>cd "C:\Users\C9995799\Downloads\helloworldMPI\Debug"*
>
> **
>
> *C:\Users\...\Downloads\helloworldMPI\Debug>mpiexec -n 2
> helloworldMPI.exe*
>
> *--------------------------------------------------------------------------*
>
> *mpiexec was unable to launch the specified application as it could
> not find an e*
>
> *xecutable:*
>
> **
>
> *Executable: helloworldMPI.exe*
>
> *Node: SOUMIWHP5003567*
>
> **
>
> *while attempting to start process rank 0.*
>
> *--------------------------------------------------------------------------*
>
> *2 total processes failed to start*
>
> **
>
> *C:\Users\...\Downloads\helloworldMPI\Debug>*
>
> --
>
> Vimal
>
> *From:*users-bounces_at_[hidden] [mailto:users-bounces_at_[hidden]]
> *On Behalf Of *Damien
> *Sent:* Thursday, June 14, 2012 3:38 PM
> *To:* Open MPI Users
> *Subject:* Re: [OMPI users] Building MPI on Windows
>
> Here's a MPI Hello World project based on your code. It runs fine on
> my machine. You'll need to change the include and lib paths as we
> discussed before to match your paths, and copy those bin files over to
> the Debug directory.
>
> Run it with this to start: "mpiexec -n 1 helloworldMPI.exe". Then
> change the -n 1 to -n x where x is the number of cores you have. Say
> yes to allowing mpiexec firewall access if that comes up.
>
> If this bombs out, there's something wrong on your machine.
>
> Damien
>
>