Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Unable to configure with f77 bindings
From: Shiqing Fan (fan_at_[hidden])
Date: 2012-06-13 09:42:00


Hi Nicola,

Which Open MPI version did you use?

What build type did you use for configuring it? For example, if you use
cmake generator "Visual Studio 10 Win64" then the whole project is
configured only for 64bit, even if you change c/c++ options. In order to
use f77, which is only 32 bit available, you have to configure the whole
project with 32 bit, i.e. cmake generator "Visual Studio 10".

Regards,
Shiqing

On 2012-06-13 3:25 PM, Nicola J. Calder wrote:
> I am trying to configure Open MPI using CMake 2.8.8 and Visual Studio
> 2005 in 32 bit mode, with Intel Fortran. The machine is a 64 bit
> machine running Windows XP 64 bit, and VS has 64 bit support.
> Configure works fine without f77 bindings, but as soon as I add this
> option, I get the error:
> Checking for working Fortran compiler...
> Microsoft (R) Incremental Linker Version 8.00.50727.762
> Copyright (C) Microsoft Corporation. All rights reserved.
> -out:testFortranCompiler.exe
> -subsystem:console
> testFortranCompiler.obj
> LIBCMT.lib(crt0dat.obj) : fatal error LNK1112: module machine type
> 'x64' conflicts with target machine type 'X86'
> Intel(R) Fortran Compiler for 32-bit applications, Version 9.1
> Build 20070322Z Package ID: W_FC_C_9.1.037
> Copyright (C) 1985-2007 Intel Corporation. All rights reserved.
> Fortran compiler ifort.exe can't compile a simple fortran program.
> CMake Error at contrib/platform/win32/CMakeModules/setup_f77.cmake:116
> (MESSAGE):
> Cannot continue. Please check Fortran compiler installation, or disable
> Fortran 77 support.
> Call Stack (most recent call first):
> contrib/platform/win32/CMakeModules/ompi_configure.cmake:616 (INCLUDE)
> CMakeLists.txt:99 (BEGIN_CONFIGURE)
> Configuring incomplete, errors occurred!
> I am using all default options, except that I have specified a
> cmake_build_type of release. Both the c and cxx compilers appear to
> be pointing to the 64 bit versions, but changing these to the 32 bit
> versions does not seem to matter.
> If I attempt to compile testFortranCompiler from a command prompt it
> compiles without any difficulties (ifort testFortranCompiler.f, with
> no other flags).
> Any ideas which options I am missing to get this to work?
>
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
---------------------------------------------------------------
Shiqing Fan
High Performance Computing Center Stuttgart (HLRS)
Tel: ++49(0)711-685-87234      Nobelstrasse 19
Fax: ++49(0)711-685-65832      70569 Stuttgart
http://www.hlrs.de/organization/people/shiqing-fan/
email: fan_at_[hidden]