Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [OMPI users] Question on ./configure error on Tru64unix (OSF1) v5.1B-6 for openmpi-1.6
From: Rayson Ho (raysonlogin_at_[hidden])
Date: 2012-06-08 11:15:59


Hi Bill,

If you *really* have time, then you can go deep into the log, and find
out why configure failed. It looks like configure failed when it tried
to compile this code:

 .text
 # .gsym_test_func
 .globl .gsym_test_func
 .gsym_test_func:
 # .gsym_test_func

 configure:26752: result: none
 configure:26756: error: Could not determine global symbol label prefix

May be it's a gcc thing?? Like your assembler is too old?? I tried it
in Cygwin, which has gcc 3.4.4, and it seems to work fine (just copy
the 5 lines of code above into a file and name it with the ".s" ext
name. Then compile it with gcc and see if you can reproduce it.

I was involved in a TOP500 project that uses AlphaServer SC ES45 nodes
(a total of 4,096 cores), and it was the #2 in TOP500 a decade ago! It
was fun back then... But I agree with Jeff, it is unlikely that Open
MPI is going to work on Tru64 - all modern processors are much faster
than Alpha and I believe even the TOP500 Alpha machines are all
powered down (even the Earth Simulator is not on the TOP500 list
anymore - that was the #1 back then!!).

Rayson

On Fri, Jun 8, 2012 at 7:07 AM, Jeff Squyres <jsquyres_at_[hidden]> wrote:
> To be honest, I don't think we've ever tested on Tru64, so I'm not surprised that it doesn't work.  Indeed, I think that it is unlikely that we will ever support Tru64.  :-(
>
> Sorry!
>
>
> On Jun 7, 2012, at 12:43 PM, <Bill.Glessner_at_[hidden]> <Bill.Glessner_at_[hidden]> wrote:
>
>>
>> Hello,
>>
>> I am having trouble with the *** Assembler section of the GNU autoconf
>> step in trying to build OpenMPI version 1.6 on an HP AlphaServer GS160
>> running Tru64unix version 5.1B-6:
>>
>> # uname -a
>> OSF1 zozma.cts.cwu.edu V5.1 2650 alpha
>>
>> The output is of the ./configure run
>> zozma(bash)% ./configure --prefix=/usr/local/OpenMPI \
>> --enable-shared --enable-static :
>>
>> ...
>>
>> *** Assembler
>> checking dependency style of gcc... gcc3
>> checking for BSD- or MS-compatible name lister (nm)... /usr/local/bin/nm -B
>> checking the name lister (/usr/local/bin/nm -B) interface... BSD nm
>> checking for fgrep... /usr/local/bin/grep -F
>> checking if need to remove -g from CCASFLAGS... no
>> checking whether to enable smp locks... yes
>> checking if .proc/endp is needed... no
>> checking directive for setting text section... .text
>> checking directive for exporting symbols... .globl
>> checking for objdump... objdump
>> checking if .note.GNU-stack is needed... no
>> checking suffix for labels... :
>> checking prefix for global symbol labels... none
>> configure: error: Could not determine global symbol label prefix
>>
>> The ./config.log is appended.
>>
>> Can anyone provide some information or suggestions on how to resolve this
>> issue?
>>

==================================================
Open Grid Scheduler - The Official Open Source Grid Engine
http://gridscheduler.sourceforge.net/

http://blogs.scalablelogic.com/