Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: [OMPI users] "-library=stlport4" neccessary for Sun C
From: Siegmar Gross (Siegmar.Gross_at_[hidden])
Date: 2012-06-06 04:38:21


Hello,

I compiled "openmpi-1.6" on "Solaris 10 sparc", "Solaris 10 x86",
and Linux (openSuSE 12.1) with "Sun C 5.12". Today I searched my
log-files for "WARNING" and found the following message.

WARNING: **************************************************************
WARNING: *** VampirTrace cannot be built due to your STL appears to
WARNING: *** be broken.
WARNING: *** Please try again re-configuring Open MPI with using
WARNING: *** the STLport4 by adding the compiler flag -library=stlport4
WARNING: *** to CXXFLAGS.
WARNING: *** Pausing to give you time to read this message...
WARNING: **************************************************************

With this recommendation I could configure and build VampirTrace
support. Perhaps somebody can add this option as default to
"configure" for "Sun C 5.12" on Solaris and Linux.

By the way it wasn't enough to "enhance" my old built because
"ompi_info" didn't know about VampirTrace in that case.

tyr fd1026 101 cd /usr/local/openmpi-1.6_64_cc/bin
tyr bin 102 ls -l ompi_info
-rwxr-xr-x 1 root root 184392 Jun 6 08:54 ompi_info
tyr bin 103 ./ompi_info | grep "Built on"
                Built on: Tue May 29 15:45:13 CEST 2012
tyr bin 104 ./ompi_info | grep Vampir
     VampirTrace support: no
tyr bin 105 ls -l vtwrapper
-rwxr-xr-x 1 root root 342816 Jun 6 08:54 vtwrapper

After rebuilding everything from scratch "ompi_info" worked as
expected.

tyr bin 106 ./ompi_info | grep Vampir
     VampirTrace support: yes

Kind regards

Siegmar