Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: [OMPI users] Error building openmpi-1.6 from copy
From: Jeremy (spritzydog_at_[hidden])
Date: 2012-06-01 14:16:49


Hi,

I am having trouble building Open MPI 1.6 with RHEL 6.2 and gcc from a
copy of the openmpi-1.6 directory.

Everything works OK if I do a simple build like:
tar xvf openmpi-1.6.tar
cd openmpi-1.6
configure --prefix=/opt/local/mpi
make
make install

However, if I do an intermediate copy of the opempi-1.6 directory then
make fails (details attached):
tar xvf openmpi-1.6.tar
cp -r openmpi-1.6 openmpi-1.6.try
cd openmpi-1.6.try
configure --prefix=/opt/local/mpi
make fails with errors like:
sh: config/ompi_get_version.sh: No such file or directory
ompi/mca/bml/Makefile.am:31: WANT_INSTALL_HEADERS does not appear in
AM_CONDITIONAL

I can get it work only if I preserve timestamps when I do the copy:
tar xvf openmpi-1.6.tar
cp -r --preserve=timestamps openmpi-1.6 openmpi-1.6.try
cd openmpi-1.6.try
configure --prefix=/opt/local/mpi
make (OK)
make install

So it seems like there is some dependency or configuration problem.
I've attached the build output. Please let me know if you have any
suggestions or if there is any other information I can provide.

Thanks,

-Jeremy