Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] mpicc, mpif90, ... not created during installation
From: denis cohen (Denis.cohen_at_[hidden])
Date: 2012-06-01 09:32:02


I have not tried separating the two options. the --help in configure
indicates that --enable-binaries is enabled by default;
--with-devel-headers isn't. Not a specialist myself so don't know the
innards of openmpi. Only thing I know is that it's now working for me.

Can try something is that would help the community. Just let me know.

Cheers,

Denis

On Fri, Jun 1, 2012 at 3:27 PM, Jeff Squyres <jsquyres_at_[hidden]> wrote:
> On Jun 1, 2012, at 8:20 AM, Aurélien Bouteiller wrote:
>
>> You need to pass the following option to configure:
>> --with-devel-headers --enable-binaries
>>
>> I don't know exactly why the default is not to build them anymore, this is a bit confusing.
>
> That is not correct -- the default is to build and install all OMPI binaries (including mpicc and friends).  If using --enable-binaries fixed the issue for you, then there's something else going on.
>
> --with-devel-headers has never been the default; it's a developer-working-with-OMPI-internals kind of feature (which <1% of our users), so you have to specifically enable it.
>
> --
> Jeff Squyres
> jsquyres_at_[hidden]
> For corporate legal information go to: http://www.cisco.com/web/about/doing_business/legal/cri/
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users