Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] mpicc link shouldn't add -ldl and -lhwloc
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2012-05-21 19:35:03


Thank you!

This is on my list to investigate; I'm sorry I haven't had a chance to look at it in detail yet.

I hope to look at this in detail later this week.

On May 21, 2012, at 4:06 PM, Orion Poplawski wrote:

> On 05/15/2012 10:37 AM, Orion Poplawski wrote:
>> See https://bugzilla.redhat.com/show_bug.cgi?id=814798
>>
>> $ mpicc -showme:link
>> -pthread -m64 -L/usr/lib64/openmpi/lib -lmpi -ldl -lhwloc
>>
>> -ldl and -lhwloc should not be listed. The user should only link against
>> libraries that they are using directly, namely -lmpi, and they should
>> explicitly add -ldl and -lhwloc if their code directly uses those libraries.
>> There does not appear to be any references to libdl or libhwloc symbols in the
>> openmpi headers which is the other place it could come in.
>>
>> configure appears to add them to opal_WRAPPER_EXTRA_LIBS which then makes its
>> way into this list.
>>
>> This report is with openmpi-1.5.5. Haven't tested with 1.6, but configure
>> looks to do the same in it.
>
> Filed https://svn.open-mpi.org/trac/ompi/ticket/3103
>
> --
> Orion Poplawski
> Technical Manager 303-415-9701 x222
> NWRA, Boulder Office FAX: 303-415-9702
> 3380 Mitchell Lane orion_at_[hidden]
> Boulder, CO 80301 http://www.nwra.com
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Jeff Squyres
jsquyres_at_[hidden]
For corporate legal information go to: http://www.cisco.com/web/about/doing_business/legal/cri/