Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [OMPI users] OpenMPI with SGE: "-np N" for mpirun needed?
From: Ricardo Reis (rreis_at_[hidden])
Date: 2012-05-09 16:22:18


On Wed, 9 May 2012, Jiri Polach wrote:

> Dear all,
>
> is "-np N" parameter needed for mpirun when running jobs under SGE
> environment? All examples in
>
> http://www.open-mpi.org/faq/?category=running#run-n1ge-or-sge
>
> show that "-np N" is used, but in my opinion it should be redundant: mpirun
> should determine all parameters from SGE environment anyway. If there is "no
> need to specify what nodes to run on" (as stated in FAQ), it should not be
> necessary to specify the number of processors either.
>
> I ran some tests and it seems that mpirun correctly gets number of processors
> from SGE, but I would like to have some more solid confirmation.

You might want to use a smaller number of processors than those made
available by SGE.

  best,

  Ricardo Reis

  'Non Serviam'

  PhD/MSc Mechanical Engineering | Lic. Aerospace Engineering

  Computational Fluid Dynamics, High Performance Computing, Turbulence
  http://www.lasef.ist.utl.pt

  Cultural Instigator @ Rádio Zero
  http://www.radiozero.pt

  http://www.flickr.com/photos/rreis/

  contacts: gtalk: kyriusan_at_[hidden] skype: kyriusan

  Institutional Address:

  Ricardo J.N. dos Reis
  IDMEC, Instituto Superior Técnico, Technical University of Lisbon
  Av. Rovisco Pais
  1049-001 Lisboa
  Portugal

                       - email sent with alpine 2.00 -