Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [OMPI users] Regarding the execution time calculation
From: Björn Adlerborn (bjorn.adlerborn_at_[hidden])
Date: 2012-05-03 08:59:08


Hi, could you also attach your current code ?

 

Regards

Björn

 

From: users-bounces_at_[hidden] [mailto:users-bounces_at_[hidden]] On
Behalf Of seshendra seshu
Sent: den 3 maj 2012 13:49
To: Open MPI Users
Subject: [OMPI users] Regarding the execution time calculation

 

Hi,
I have written an parallel program and when i run my program on 4,8,16 nodes
and calculated the execution time at master using MPI_Wtime in master node.
The problem the execution time is increasing rapidly like NON parallel
program-55 sec, and for parallel program 2-nodes--60sec , 4-nodes 74sec,
8-node--120 sec and for 16 nodes---for 180 sec. can i know my problem in
parallel version actually the time needs to be decreased but it is
increasing i dont the reason. i have calculated my time as shown below

main(argv,argc)
{
double start,end;
start= MPI_Wtime;
// done some work
{
// start send from master node and receiving it
end =MPI_Wtime;
cout<<"execution time"<<end-start;
}
//in slave nodes done some work
 MPI_Finalize;
}

Please help me in solving this problem.

-- 
 WITH REGARDS
M.L.N.Seshendra