Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] regarding the problem occurred while running anmpi programs
From: seshendra seshu (seshu199_at_[hidden])
Date: 2012-04-25 12:47:22


Hi,
I have read the FAQ for ssh and followed it but i have got the following
error

[master_at_ip-10-80-106-70 .ssh]$ eval
'ssh-agent'

SSH_AUTH_SOCK=/tmp/ssh-MOnArn9942/agent.9942; export SSH_AUTH_SOCK;
SSH_AGENT_PID=9943; export SSH_AGENT_PID;
echo Agent pid 9943;
[master_at_ip-10-80-106-70 .ssh]$ ssh-add $home/master/.ssh/id_dsa
Could not open a connection to your authentication agent.

so how can i solve it.

Thanking you

With Regards
seshendra

On Wed, Apr 25, 2012 at 6:16 PM, Jeff Squyres <jsquyres_at_[hidden]> wrote:

> I would really suggest doing a little reading in the FAQ. It talks about
> setting up ssh keys, etc.
>
> http://www.open-mpi.org/faq/?category=rsh
>
>
> On Apr 25, 2012, at 12:03 PM, seshendra seshu wrote:
>
> > Hi,
> > Thanks its has worked but when i tried to run for a 2 nodes , i have got
> the following error
> >
> > [master_at_ip-10-80-106-70 ~]$ mpirun -n 2 --hostfile hostfile out
> > Permission denied (publickey,gssapi-with-mic).
> >
> --------------------------------------------------------------------------
> > A daemon (pid 9923) died unexpectedly with status 255 while attempting
> > to launch so we are aborting.
> >
> > There may be more information reported by the environment (see above).
> >
> > This may be because the daemon was unable to find all the needed shared
> > libraries on the remote node. You may set your LD_LIBRARY_PATH to have
> the
> > location of the shared libraries on the remote nodes and this will
> > automatically be forwarded to the remote nodes.
> >
> --------------------------------------------------------------------------
> >
> --------------------------------------------------------------------------
> > mpirun noticed that the job aborted, but has no info as to the process
> > that caused that situation.
> >
> --------------------------------------------------------------------------
> > mpirun: clean termination accomplished
> >
> > [master_at_ip-10-80-106-70 ~]$
> >
> >
> > so please help me in solving this.
> >
> > Thanking you.
> >
> >
> > On Wed, Apr 25, 2012 at 5:48 PM, tyler.balson_at_[hidden] <
> tyler.balson_at_[hidden]> wrote:
> > export LD_LIBRARY_PATH= [location of library] leave out the
> :$LD_LIBRARY_PATH
> > From: users-bounces_at_[hidden] [users-bounces_at_[hidden]] on behalf
> of seshendra seshu [seshu199_at_[hidden]]
> > Sent: Wednesday, April 25, 2012 10:43 AM
> > To: Open MPI Users
> > Subject: Re: [OMPI users] regarding the problem occurred while running
> anmpi programs
> >
> > Hi
> > I have exported the library files as below
> >
> > [master_at_ip-10-80-106-70 ~]$ export
> LD_LIBRARY_PATH=/usr/local/openmpi-1.4.5/lib:$LD_LIBRARY_PATH
> > [master_at_ip-10-80-106-70 ~]$ mpirun --prefix /usr/local/openmpi-1.4.5 -n
> 1 --hostfile hostfile out
> > out: error while loading shared libraries: libmpi_cxx.so.0: cannot open
> shared object file: No such file or directory
> > [master_at_ip-10-80-106-70 ~]$ mpirun --prefix /usr/local/lib/ -n 1
> --hostfile hostfile out
> > out: error while loading shared libraries: libmpi_cxx.so.0: cannot open
> shared object file: No such file or directory
> >
> > But still iam getting the same error.
> >
> >
> >
> >
> >
> > On Wed, Apr 25, 2012 at 5:36 PM, Jeff Squyres (jsquyres) <
> jsquyres_at_[hidden]> wrote:
> > See the FAQ item I cited.
> >
> > Sent from my phone. No type good.
> >
> > On Apr 25, 2012, at 11:24 AM, "seshendra seshu" <seshu199_at_[hidden]>
> wrote:
> >
> >> Hi
> >> now i have created an used and tried to run the program but i got the
> following error
> >>
> >> [master_at_ip-10-80-106-70 ~]$ mpirun -n 1 --hostfile hostfile out
> >> out: error while loading shared libraries: libmpi_cxx.so.0: cannot open
> shared object file: No such file or directory
> >>
> >>
> >> thanking you
> >>
> >>
> >>
> >> On Wed, Apr 25, 2012 at 5:12 PM, Jeff Squyres <jsquyres_at_[hidden]>
> wrote:
> >> On Apr 25, 2012, at 11:06 AM, seshendra seshu wrote:
> >>
> >> > so should i need to create an user and run the mpi program. or how
> can i run in cluster
> >>
> >> It is a "best practice" to not run real applications as root (e.g., MPI
> applications). Create a non-privlidged user to run your applications.
> >>
> >> Then be sure to set your LD_LIBRARY_PATH if you installed Open MPI into
> a non-system-default location. See this FAQ item:
> >>
> >> http://www.open-mpi.org/faq/?category=running#adding-ompi-to-path
> >>
> >> --
> >> Jeff Squyres
> >> jsquyres_at_[hidden]
> >> For corporate legal information go to:
> http://www.cisco.com/web/about/doing_business/legal/cri/
> >>
> >>
> >> _______________________________________________
> >> users mailing list
> >> users_at_[hidden]
> >> http://www.open-mpi.org/mailman/listinfo.cgi/users
> >>
> >>
> >>
> >> --
> >> WITH REGARDS
> >> M.L.N.Seshendra
> >> _______________________________________________
> >> users mailing list
> >> users_at_[hidden]
> >> http://www.open-mpi.org/mailman/listinfo.cgi/users
> >
> > _______________________________________________
> > users mailing list
> > users_at_[hidden]
> > http://www.open-mpi.org/mailman/listinfo.cgi/users
> >
> >
> >
> > --
> > WITH REGARDS
> > M.L.N.Seshendra
> >
> > _______________________________________________
> > users mailing list
> > users_at_[hidden]
> > http://www.open-mpi.org/mailman/listinfo.cgi/users
> >
> >
> >
> > --
> > WITH REGARDS
> > M.L.N.Seshendra
> > _______________________________________________
> > users mailing list
> > users_at_[hidden]
> > http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>
> --
> Jeff Squyres
> jsquyres_at_[hidden]
> For corporate legal information go to:
> http://www.cisco.com/web/about/doing_business/legal/cri/
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>

-- 
 WITH REGARDS
M.L.N.Seshendra