Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [OMPI users] MPI doesn't recognize multiple cores available on multicore machines
From: Jingcha Joba (pukkimonkey_at_[hidden])
Date: 2012-04-25 11:58:24


My bad. I did not read the bottom part of the email.
Not sure If this would help, but can u try, --mca btl sm,self ?

--
Sent from my iPhone
On Apr 24, 2012, at 3:46 PM, Kyle Boe <boex0040_at_[hidden]> wrote:
> Right, I tried using a hostfile, and it made no difference. This is running OpenMPI 1.4.4 on CentOS 5.x machines. The original issue was an error trap built into my code, where it said one of the cores was asking for information it already owned. I'm sorry to be vague, but I can't share anything from the code in this forum. Basically, it is a CFD code, parallelized by splitting the grid points in the simulation up amongst the processors assigned to the job. As a pre-processing step, each processor must figure out which other processors it must communicate with by virtue of sharing neighboring gridpoints. The error I received told me that the grid points were not being split amongst different processors. I have used this exact same code using OpenMPI on other (larger) architectures, which, combined with the MPI error I shared before, leads me to believe I must have something not configured correctly, or there is some run time option I'm not setting properly, etc.
> 
> Thanks
> 
> Kyle
> 
> On Tue, Apr 24, 2012 at 4:15 PM, <users-request_at_[hidden]> wrote:
> From: Ralph Castain <rhc_at_[hidden]>
> Subject: Re: [OMPI users] MPI doesn't recognize multiple cores
>        available on    multicore machines
> To: Open MPI Users <users_at_[hidden]>
> Message-ID: <F9D4FCE5-9974-4814-9BCF-A39124961B32_at_[hidden]>
> Content-Type: text/plain; charset=us-ascii
> 
> You don't need a hostfile to run multiple procs on the localhost.
> 
> What version of OMPI are you using? What was the original issue?
> 
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users