Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [OMPI users] regarding the problem occurred while running an mpi programs
From: seshendra seshu (seshu199_at_[hidden])
Date: 2012-04-25 11:24:28


Hi
now i have created an used and tried to run the program but i got the
following error

[master_at_ip-10-80-106-70 ~]$ mpirun -n 1 --hostfile hostfile
out

out: error while loading shared libraries: libmpi_cxx.so.0: cannot open
shared object file: No such file or directory

thanking you

On Wed, Apr 25, 2012 at 5:12 PM, Jeff Squyres <jsquyres_at_[hidden]> wrote:

> On Apr 25, 2012, at 11:06 AM, seshendra seshu wrote:
>
> > so should i need to create an user and run the mpi program. or how can i
> run in cluster
>
> It is a "best practice" to not run real applications as root (e.g., MPI
> applications). Create a non-privlidged user to run your applications.
>
> Then be sure to set your LD_LIBRARY_PATH if you installed Open MPI into a
> non-system-default location. See this FAQ item:
>
> http://www.open-mpi.org/faq/?category=running#adding-ompi-to-path
>
> --
> Jeff Squyres
> jsquyres_at_[hidden]
> For corporate legal information go to:
> http://www.cisco.com/web/about/doing_business/legal/cri/
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>

-- 
 WITH REGARDS
M.L.N.Seshendra