Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Error while loading shared libraries
From: Rohan Deshpande (rohand87_at_[hidden])
Date: 2012-04-02 03:56:20


Yes, I am trying to run the program using multiple hosts.

The program executes fine but *does not use any slaves* when I run

  *mpirun -np 8 hello --hostfile slaves*

The program throws error saying *shared libraries not found* when I run

 * mpirun --hostfile slaves -np 8*

On Mon, Apr 2, 2012 at 2:52 PM, Rayson Ho <raysonlogin_at_[hidden]> wrote:

> On Sun, Apr 1, 2012 at 11:27 PM, Rohan Deshpande <rohand87_at_[hidden]>
> wrote:
> > error while loading shared libraries: libmpi.so.0: cannot open shared
> > object file no such object file: No such file or directory.
>
> Were you trying to run the MPI program on a remote machine?? If you
> are, then make sure that each machine has the libraries installed (or
> you can install Open MPI on an NFS directory).
>
> Rayson
>
> =================================
> Open Grid Scheduler / Grid Engine
> http://gridscheduler.sourceforge.net/
>
> Scalable Grid Engine Support Program
> http://www.scalablelogic.com/
>
>
> >
> > When I run using - mpirun -np 1 ldd hello the following libraries are not
> > found
> > 1. libmpi.so.0
> > 2. libopen-rte.so.0
> > 3. libopen.pal.so.0
> >
> > I am using openmpi version 1.4.5. Also PATH and LD_LIBRARY_PATH variables
> > are correctly set and 'which mpicc' returns correct path
> >
> > Any help would be highly appreciated.
> >
> > Thanks
> >
> >
> >
> >
> >
> >
> > _______________________________________________
> > users mailing list
> > users_at_[hidden]
> > http://www.open-mpi.org/mailman/listinfo.cgi/users
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>

-- 
Best Regards,
ROHAN DESHPANDE