Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] (no subject)
From: Addepalli, Srirangam V (srirangam.v.addepalli_at_[hidden])
Date: 2012-03-16 08:51:53


This usually means you library path is not updated to find mpilibrarues. You can fix this many ways, basic two steps are

1. Identify location of your libraries (use locate, find )
2. Add it to your Library path. ( export LD_LIBRARY_PATH or make changes in .bashrc or /etc/ld.so.conf)

Rangam
________________________________________
From: users-bounces_at_[hidden] [users-bounces_at_[hidden]] On Behalf Of jody [jody.xha_at_[hidden]]
Sent: Friday, March 16, 2012 4:04 AM
To: Open MPI Users
Subject: Re: [OMPI users] (no subject)

Hi

Did you run your program with mpirun?
For example:
   mpirun -np 4 ./a.out

jody

On Fri, Mar 16, 2012 at 7:24 AM, harini.s .. <hharinis8_at_[hidden]> wrote:
> Hi ,
>
> I am very new to openMPI and I just installed openMPI 4.1.5 on Linux
> platform. Now am trying to run the examples in the folder got
> downloaded. But when i run , I got this
>
>>> a.out: error while loading shared libraries: libmpi.so.0: cannot open shared object file: No such file or directory
>
> I got a.out when I compile hello_c.c using mpicc command.
> please help me to resolve this problem.
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
_______________________________________________
users mailing list
users_at_[hidden]
http://www.open-mpi.org/mailman/listinfo.cgi/users