Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] orted daemon not found! --- environment not passed to slave nodes
From: Yiguang Yan (yanyg_at_[hidden])
Date: 2012-03-02 09:48:44


Hi Jeff, Ralph--

Please let me follow the thread, here are what I observed:

(All with the same test script test.bash I post in my previous emails, so run with app file fed to mpirun command.)

(1) If I put the --prefix in the app file, on each line of it, it works fine as Jeff said.

(2) Since in the manual, it is said that the full path of mpirun is the same as setting "--prefix". However, with app file,
this is not the case. Without "--prefix" on each line of the app file, the full path of mpirun does not work.

(3) With "--prefix $adinahome" set on each line of the app file, it is exclusively put, on each node, the
$adinahome/bin into the PATH, and $adinahome/lib into the LD_LIBRARY_PATH(not the $adinahome/lib64 as said
in mpirun manual(v1.4.x)). The envars $PATH and $LD_LIBARARY_PATH set in test.bash script only affect the
envars on the submitting node(gulftown in my case). No $PATH or $LD_LIBRARY_PATH is passed to slave nodes
even if I use "-x PATH -x LD_LIBRARY_PATH", either fed to mpirun or put on each line of the app file. I am not sure
if this is intended, since "--prefix" overwrite the effect of "-x" option, this is different from what I see from the mpirun
man page.

I have another question about the btl used for communication. I noticed that rsh is using the tcp for connection, I
understand that tcp may be used for initial connection, but how can I know that openib(infiniband) btl is used for my
data communication? Any explicit way?

Thanks,
Yiguang