Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] InfiniBand path migration not working
From: Shamis, Pavel (shamisp_at_[hidden])
Date: 2012-02-29 11:02:46


>
>> On Tue, Feb 28, 2012 at 11:34 AM, Shamis, Pavel <shamisp_at_[hidden]> wrote:
>> I reviewed the code and it seems to be ok :) The error should be reported if the port migration is already happened once (port 1 to port 2), and now you are trying to shutdown port 2 and MPI reports that it can't migrate anymore. It assumes that port 1 is still down and it can't go back to from port 2 to port 1.
>
> In my test case I never try to shutdown port 2.
> I start with both ports cabled up.
> Then I start the MPI test
> Then I unplug the Port 1 cable.
> I leave Port 2 alone. I expect the application to just keep using Port 2.
>
> So I expect the migration from Port 1 to Port 2 when I unplug the
> cable. But I don't expect any more migration after that.

Then we have some bug there :-
)
>
>>
>> Can you please build open mpi in debug mode and try to run it in verbose mode. It will help to understand better the scenario.
>
> I've recompiled with debug mode(configure --enable-debug). The
> resulting output (mpirun --mca btl_base_verbose 1) is too large to
> send (28 MB). Are there specific lines you are looking for? Or do you
> have a preferred method for sending you a text file?

I would like to see all the file.
28MB is it the size after compression ?

I think gmail supports up to 25Mb.
You may try to create gzip file and then slice it using "split" command.

Regards,
Pasha