Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [OMPI users] help: sm btl does not work when I specify the same host twice or more in the node list
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2012-02-16 10:18:13


On Feb 16, 2012, at 9:09 AM, yanyg_at_[hidden] wrote:

> (2) Solution to this issue:
>
> You may set the $TMPDIR to a same directory on the same host if
> possible; or you could setenv OMPI_PREFIX_ENV to a common
> directory for MPI processes on the same host while keeping your
> $TMPDIR setting. either way is verified and working fine for me!

A clarification on this...

I found OMPI_PREFIX_ENV through some code diving, and it looks like this is an old name from previous logic. We'll actually be removing it from our SVN trunk shortly.

I think the right answer here is to use the orte_tmpdir_base MCA parameter:

    mpirun --mca orte_tmpdir_base /tmp ...

This will tell OMPI where to put the session directory for all processes (even if their $TMPDIRs are different from each other). This should be used instead of setting OMPI_PREFIX_ENV.

-- 
Jeff Squyres
jsquyres_at_[hidden]
For corporate legal information go to:
http://www.cisco.com/web/about/doing_business/legal/cri/