Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Different Prefix for different nodes
From: Tohiko Looka (tohiko.looka_at_[hidden])
Date: 2012-02-15 12:47:04


Hello Jeff,

Yes, I tried that and it worked.. Thanks
But I hope the people behind OpenMPI will correct this in the documentation

On Wed, Feb 15, 2012 at 7:08 PM, Jeff Squyres <jsquyres_at_[hidden]> wrote:

> On Feb 14, 2012, at 4:06 PM, Tohiko Looka wrote:
>
> > I'm trying to run my application on different nodes; each with a
> different path to OpenMPI libraries and binaries.
> > According to the documentation I can set '-prefix' on a per-context
> basis, so I can set '-prefix' differently
> > for each node, but I wasn't able to do it and I didn't find an example
>
> Yoinks -- that might be incorrect documentation. I'm pretty sure --prefix
> is a global switch.
>
> If you have OMPI installed in different locations on different nodes,
> --prefix might not be a good solution. Instead, you might well want to set
> your PATH/LD_LIBRARY_PATH in the shell startup files on each node (e.g.,
> $HOME/.bashrc) to values that are relevant for that node.
>
> --
> Jeff Squyres
> jsquyres_at_[hidden]
> For corporate legal information go to:
> http://www.cisco.com/web/about/doing_business/legal/cri/
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>