Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] O-MPI Support for Windows 7
From: Shiqing Fan (fan_at_[hidden])
Date: 2012-02-07 08:37:15


I'm afraid "--mca plm rsh" is not going to work. James is using a
Windows build, which doesn't have the rsh plm module.

There are only two plm modules for windows:
MCA plm: process (MCA ...
MCA plm: ccp (MCA ...

I think the binaries built by James contains only the process module,
which is internaly using WMI. So there is no way to switch to ssh or
rsh, because they are not built.

To use ssh, one has to build Open MPI source under Cygwin, using the
auto-tools chain (the same as on Linux). Unfortunately, the CMake
support in OMPI was only for the native windows build, it won't work
under Cygwin.

On 2012-02-07 1:51 PM, George Bosilca wrote:
> Let's try to force the usage of ssh.
>
> First try:
>
> mpirun --mca plm rsh hostname
>
> If not, go in the installation directory and rename
> lib/openmpi/mca_plm_rsh.* to something without the .la and .so
> extension. Then re-run the hostname via mpirun.
>
> george.
>
> On Feb 7, 2012, at 06:32 , James Torossian wrote:
>
>> Hi Shiqing,
>> I agree. I think that I am somehow using WMI, but this is happening
>> both with the Open-MPI windows binary (OpenMPI_v1.5.4-1_win32.exe)
>> and also with versions of the binaries I built (1.4.3 & 1.5.1 from svn).
>> What do I have to do to get OpenMPI to use ssh instead of WMI. From
>> what I can see of the configuration with ompi_info, the following
>> seems correct:
>> $ ompi_info -all
>> Package: Open MPI hpcfan_at_VISCLUSTER26 Distribution
>> Open MPI: 1.5.4
>> Open MPI SVN revision: r25060
>> Open MPI release date: Aug 18, 2011
>> Open RTE: 1.5.4
>> Open RTE SVN revision: r25060
>> Open RTE release date: Aug 18, 2011
>> OPAL: 1.5.4
>> OPAL SVN revision: r25060
>> OPAL release date: Aug 18, 2011
>> Ident string: 1.5.4
>> ….
>> MCA orte: parameter "orte_rsh_agent" (current value: <ssh : rsh>, ….
>> ….
>> MCA plm: parameter "plm_rsh_agent" (current value: <ssh : rsh>, ….
>> ….
>> Is there a cmake configuration option I need to set for a Windows
>> build to use ssh? Is there some environment or package configuration
>> option I need to set?
>> Thanks again for your help, I am keen to know what I am missing.
>> Best regards,
>> Jim
>> *From:*Shiqing Fan [mailto:fan_at_[hidden]]
>> *Sent:*Tuesday, February 07, 2012 8:20 PM
>> *To:*Open MPI Users; james.torossian_at_[hidden]
>> <mailto:james.torossian_at_[hidden]>
>> *Cc:*Ralph Castain
>> *Subject:*Re: [OMPI users] O-MPI Support for Windows 7
>> Hi James,
>>
>> One other possibility could be that ssh is actually not used at all.
>> Did you build Open MPI under Cygwin? Is the ssh module shown up in
>> the ompi_info output?
>>
>> The user credential message looks very familiar to me as it seems
>> from the WMI (Windows Management Instrumentation) module, where the
>> 'save credential' option has not been implemented.
>>
>> Shiqing
>>
>> On 2012-02-07 4:11 AM, Ralph Castain wrote:
>> Afraid I'm no OpenSSH expert, but it sounds like there is an issue
>> with its configuration. Check out the OpenSSH config options to see
>> if something fits.
>> I did a quick search and found this, as an example:
>> http://mah.everybody.org/docs/ssh
>> Note the need to run ssh-agent to cache login credentials.
>> On Feb 6, 2012, at 5:05 PM, James Torossian wrote:
>>
>>
>> Hi all,
>> I am trying to setup Open-MPI across two Windows 7 machines with UAC
>> disabled ……
>> Cygwin with OpenSSH is installed, and I can successfully ssh to each
>> machine without entry of username and password:
>> JimT_at_JimT-PC ~
>> $ ssh NanoOneQuad
>> Last login: Tue Feb 7 01:42:02 2012 from jimt-pc
>> JimT_at_NanoOneQuad ~
>> $
>> Regardless of this, mpirun insists on asking for a username and
>> password; then asks to save credentials, but if selected, responds
>> with not implemented. If saving credentials is not selected, then I
>> can see that the task starts on the other machine (in task manager)
>> and that the task runs to completion OK:
>> JimT_at_JimT-PC ~
>> $ mpirun -H NanoOneQuad ipconfig.exe
>> connecting to NanoOneQuad
>> username:JimT
>> password:**************
>> Save Credential?(Y/N) y
>> [JimT-PC:03784] This feature hasn't been implemented yet.
>> JimT_at_JimT-PC ~
>> $ mpirun -H NanoOneQuad ipconfig.exe
>> connecting to NanoOneQuad
>> username:JimT
>> password:**************
>> Save Credential?(Y/N) n
>> JimT_at_JimT-PC ~
>> $
>> Please let me know what I have missed. I have gone through the FAQs
>> and have rebuilt the windows version but can’t seem to get past this.
>> Thanks and best regards,
>> Jim
>> _______________________________________________
>> users mailing list
>> users_at_[hidden] <mailto:users_at_[hidden]>
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>
>>
>>
>> _______________________________________________
>> users mailing list
>> users_at_[hidden] <mailto:users_at_[hidden]>
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>
>>
>>
>> --
>> ---------------------------------------------------------------
>> Shiqing Fan
>> High Performance Computing Center Stuttgart (HLRS)
>> Tel: ++49(0)711-685-87234 Nobelstrasse 19
>> Fax: ++49(0)711-685-65832 70569 Stuttgart
>> http://www.hlrs.de/organization/people/shiqing-fan/
>> email:fan_at_[hidden] <mailto:fan_at_[hidden]>
>> _______________________________________________
>> users mailing list
>> users_at_[hidden] <mailto:users_at_[hidden]>
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>

-- 
---------------------------------------------------------------
Shiqing Fan
High Performance Computing Center Stuttgart (HLRS)
Tel: ++49(0)711-685-87234      Nobelstrasse 19
Fax: ++49(0)711-685-65832      70569 Stuttgart
http://www.hlrs.de/organization/people/shiqing-fan/
email: fan_at_[hidden]