Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] O-MPI Support for Windows 7
From: James Torossian (j.torossian_at_[hidden])
Date: 2012-02-07 03:56:32


Hi George,

 

Thanks for your prompt reply, it is much appreciated. In response to your
questions:

 

Yes, I can execute ipconfig.exe through ssh without having to provide a
username or password (both in an ssh session and the command line).

 

I have run hostname as requested (the hostname is not returned but the
process launches on the remote machine and terminates) ...

 

JimT_at_JimT-PC ~

$ ssh NanoOneQuad

Last login: Tue Feb 7 19:35:14 2012 from jimt-pc

 

JimT_at_NanoOneQuad ~

$ hostname

NanoOneQuad

 

JimT_at_NanoOneQuad ~

$ exit

logout

Connection to NanoOneQuad closed.

 

JimT_at_JimT-PC ~

$ ssh NanoOneQuad hostname

NanoOneQuad

 

JimT_at_JimT-PC ~

$ mpirun -H NanoOneQuad hostname.exe

connecting to NanoOneQuad

username:JimT

password:**************

Save Credential?(Y/N) n

 

JimT_at_JimT-PC ~

$

 

Please let me know any ideas you may have.

 

Thanks again,

Jim

 

 

 

 

From: George Bosilca [mailto:bosilca_at_[hidden]]
Sent: Tuesday, February 07, 2012 2:10 PM
To: james.torossian_at_[hidden]; Open MPI Users
Subject: Re: [OMPI users] O-MPI Support for Windows 7

 

James,

 

There is no mention about username or password in OMPI. I guess one of the
applications used in the process, either the ssh or the ipconfig.exe is
missing the current context to be executed without a higher level of
credentials.

 

Can you execute ipconfig.exe once connected through ssh without having to
provide the username and password? If yes, can you execute hostname through
mpirun instead of ipconfig.exe?

 

  george.

 

 

On Feb 6, 2012, at 19:05 , James Torossian wrote:

Hi all,

I am trying to setup Open-MPI across two Windows 7 machines with UAC
disabled ..

 

Cygwin with OpenSSH is installed, and I can successfully ssh to each machine
without entry of username and password:

 

JimT_at_JimT-PC ~

$ ssh NanoOneQuad

Last login: Tue Feb 7 01:42:02 2012 from jimt-pc

 

JimT_at_NanoOneQuad ~

$

 

Regardless of this, mpirun insists on asking for a username and password;
then asks to save credentials, but if selected, responds with not
implemented. If saving credentials is not selected, then I can see that the
task starts on the other machine (in task manager) and that the task runs to
completion OK:

 

JimT_at_JimT-PC ~

$ mpirun -H NanoOneQuad ipconfig.exe

connecting to NanoOneQuad

username:JimT

password:**************

Save Credential?(Y/N) y

[JimT-PC:03784] This feature hasn't been implemented yet.

 

JimT_at_JimT-PC ~

$ mpirun -H NanoOneQuad ipconfig.exe

connecting to NanoOneQuad

username:JimT

password:**************

Save Credential?(Y/N) n

 

JimT_at_JimT-PC ~

$

 

Please let me know what I have missed. I have gone through the FAQs and have
rebuilt the windows version but can't seem to get past this.

 

Thanks and best regards,

Jim

 

_______________________________________________
users mailing list
users_at_[hidden]
http://www.open-mpi.org/mailman/listinfo.cgi/users