Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Latest Intel Compilers (ICS, version 12.1.0.233 Build 20110811) issues ...
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2012-02-01 14:30:29


I just added it:

    http://www.open-mpi.org/faq/?category=troubleshooting#intel-12.1-compiler

On Feb 1, 2012, at 12:41 PM, Jeff Squyres wrote:

> I think we need to add something to the FAQ so that it's googleable "The Intel 12.1 Linux compilers before 12.1.2 are busted. Upgrade to at least 12.1.2, and OMPI should compile and work fine."
>
>
> On Feb 1, 2012, at 3:34 AM, Götz Waschk wrote:
>
>> On Tue, Jan 31, 2012 at 5:20 PM, Richard Walsh
>> <Richard.Walsh_at_[hidden]> wrote:
>>> in the malloc.c routine in 1.5.5. Perhaps you should lower the optimization
>>> level to zero and see what you get.
>> Hi Richard,
>>
>> thanks for the suggestion. I was able to solve the problem by
>> upgrading the Intel Compiler to version 12.1.2 and recompiling the
>> openmpi runtime with unchanged options. Now I cannot reproduce that
>> crash. I'll have to test some more, but I think the problem is solved.
>>
>> Thanks, Götz
>>
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>
> --
> Jeff Squyres
> jsquyres_at_[hidden]
> For corporate legal information go to:
> http://www.cisco.com/web/about/doing_business/legal/cri/
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Jeff Squyres
jsquyres_at_[hidden]
For corporate legal information go to:
http://www.cisco.com/web/about/doing_business/legal/cri/