Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Strange recursive "no" error message when compiling 1.5 series with fault tolerance enabled
From: Josh Hursey (jjhursey_at_[hidden])
Date: 2012-01-26 16:26:14


It looks like Jeff beat me too it. The problem was with a missing 'test' in
the configure script. I'm not sure how it creeped in there, but the fix is
in the pipeline for the next 1.5 release. The ticket to track the progress
of this patch is on the following ticket:
  https://svn.open-mpi.org/trac/ompi/ticket/2979

Thanks for the bug report!

-- Josh

On Thu, Jan 26, 2012 at 4:16 PM, Jeff Squyres <jsquyres_at_[hidden]> wrote:

> Doh! That's a fun one. Thanks for the report!
>
> I filed a fix; we'll get this in very shortly (looks like the fix is
> already on the trunk, but somehow got missed on the v1.5 branch).
>
>
> On Jan 26, 2012, at 3:42 PM, David Akin wrote:
>
> > I can build OpenMPI with FT on my system if I'm using 1.4 source, but
> > if I use any of the 1.5 series, I get hung in a strange "no" loop at the
> > beginning of the compile (see below):
> >
> > + ./configure --build=x86_64-unknown-linux-gnu
> > --host=x86_64-unknown-linux-gnu --target=x86_64-redhat-linux-gnu
> > --program-prefix= --prefix=/usr/mpi/intel/openmpi-1.5-ckpt
> > --exec-prefix=/usr/mpi/intel/openmpi-1.5-ckpt
> > --bindir=/usr/mpi/intel/openmpi-1.5-ckpt/bin
> > --sbindir=/usr/mpi/intel/openmpi-1.5-ckpt/sbin
> > --sysconfdir=/usr/mpi/intel/openmpi-1.5-ckpt/etc
> > --datadir=/usr/mpi/intel/openmpi-1.5-ckpt/share
> > --includedir=/usr/mpi/intel/openmpi-1.5-ckpt/include
> > --libdir=/usr/mpi/intel/openmpi-1.5-ckpt/lib64
> > --libexecdir=/usr/mpi/intel/openmpi-1.5-ckpt/libexec
> > --localstatedir=/var --sharedstatedir=/var/lib --mandir=/usr/share/man
> > --infodir=/usr/share/info --enable-ft-thread --with-ft=cr
> > --enable-opal-multi-threads
> >
> > .
> > .
> > .
> >
> >
> ============================================================================
> > == System-specific tests
> >
> ============================================================================
> > checking checking for type of MPI_Offset... long long
> > checking checking for an MPI datatype for MPI_Offset... MPI_LONG_LONG
> > checking for _SC_NPROCESSORS_ONLN... yes
> > checking whether byte ordering is bigendian... no
> > checking for broken qsort... no
> > checking if word-sized integers must be word-size aligned... no
> > checking if C compiler and POSIX threads work as is... no
> > checking if C++ compiler and POSIX threads work as is... no
> > checking if F77 compiler and POSIX threads work as is... yes
> > checking if C compiler and POSIX threads work with -Kthread... no
> > checking if C compiler and POSIX threads work with -kthread... no
> > checking if C compiler and POSIX threads work with -pthread... yes
> > checking if C++ compiler and POSIX threads work with -Kthread... no
> > checking if C++ compiler and POSIX threads work with -kthread... no
> > checking if C++ compiler and POSIX threads work with -pthread... yes
> > checking for PTHREAD_MUTEX_ERRORCHECK_NP... yes
> > checking for PTHREAD_MUTEX_ERRORCHECK... yes
> > checking for working POSIX threads package... yes
> > checking if C compiler and Solaris threads work... no
> > checking if C++ compiler and Solaris threads work... no
> > checking if F77 compiler and Solaris threads work... no
> > checking for working Solaris threads package... no
> > checking for type of thread support... posix
> > checking if threads have different pids (pthreads on linux)... no
> > checking if want OPAL thread support... yes
> > checking if want fault tolerance thread... = no
> > = no
> > = no
> > = no
> > = no
> > = no
> > = no
> > = no
> > = no
> > = no
> > = no
> > = no
> > = no
> > .
> > .
> > .
> >
> >
> > The system just keeps repeating "no" over and over infinitely.
> >
> > I'm on RHEL6 2.6.32-220.2.1.el6.x86_64. I've tried the
> > following OpenMPI 1.5 series tarballs with the same results:
> >
> > openmpi-1.5.5rc1.tar.bz2
> > openmpi-1.5.5rc2r25765.tar.bz2
> > openmpi-1.5.5rc2r25773.tar.bz2
> >
> > Any guidance is appreciated.
> > Thanks!
> > Dave
> > _______________________________________________
> > users mailing list
> > users_at_[hidden]
> > http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>
> --
> Jeff Squyres
> jsquyres_at_[hidden]
> For corporate legal information go to:
> http://www.cisco.com/web/about/doing_business/legal/cri/
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>

-- 
Joshua Hursey
Postdoctoral Research Associate
Oak Ridge National Laboratory
http://users.nccs.gov/~jjhursey