Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] localhost only
From: Ralph Castain (rhc_at_[hidden])
Date: 2012-01-19 10:47:41


No argument - we should support it. I was on travel and just got back, so I'll take a look and see why we aren't doing so.

On Jan 17, 2012, at 9:38 AM, Gustavo Correa wrote:

> But that would be yet another legitimate singleton-edge-case that OpenMPI could
> proudly handle, wouldn't it?
> No network connection, yet OpenMPI is still operational in a standalone insular machine.
> IMHO, MM made a good case for his 'commuter MPI'. :)
> Times change, I would never have thought that people are doing
> parallel programming and HPC in the subway.
> Gus Correa
>
> On Jan 17, 2012, at 11:25 AM, Ralph Castain wrote:
>
>> I think it won't help - it looks like mpirun itself aborts if it only finds a loopback available.
>>
>> On Tue, Jan 17, 2012 at 9:24 AM, Gustavo Correa <gus_at_[hidden]> wrote:
>> MM
>> Have you tried adding '-mca btl sm,self' to your mpirun command line,
>> as suggested by Terry? [despite the low chances that it would work ...]
>> If somehow the loopback interface is up, wouldn't it work?
>> Gus Correa
>>
>> On Jan 17, 2012, at 7:01 AM, MM wrote:
>>
>>> Gus, unfortunately, it doesn't seem to change the error.
>>> Ralph, with the wireless adapter disabled, netstat on winxp still shows these ports as listening:
>>> Shouldn't the MS TCP Loopback interface allow the tcp ports to be created?
>>>
>>>
>>>> netstat -an
>>>
>>> Active Connections
>>>
>>> Proto Local Address Foreign Address State
>>> TCP 0.0.0.0:135 0.0.0.0:0 LISTENING
>>> TCP 0.0.0.0:445 0.0.0.0:0 LISTENING
>>> TCP 0.0.0.0:2967 0.0.0.0:0 LISTENING
>>> TCP 0.0.0.0:3389 0.0.0.0:0 LISTENING
>>> TCP 0.0.0.0:4445 0.0.0.0:0 LISTENING
>>> TCP 0.0.0.0:57632 0.0.0.0:0 LISTENING
>>> TCP 127.0.0.1:1025 0.0.0.0:0 LISTENING
>>> TCP 127.0.0.1:62514 0.0.0.0:0 LISTENING
>>>
>>>> route print
>>> ===========================================================================
>>> Interface List
>>> 0x1 ........................... MS TCP Loopback interface
>>> 0x2 ...00 24 d6 10 05 4e ...... Intel(R) WiFi Link 5100 AGN - Packet Scheduler Miniport
>>> ===========================================================================
>>> ===========================================================================
>>> Active Routes:
>>> Network Destination Netmask Gateway Interface Metric
>>> 127.0.0.0 255.0.0.0 127.0.0.1 127.0.0.1 1
>>> 255.255.255.255 255.255.255.255 255.255.255.255 2 1
>>> ===========================================================================
>>> Persistent Routes:
>>> None
>>>
>>> -----Original Message-----
>>> From: users-bounces_at_[hidden] [mailto:users-bounces_at_[hidden]] On Behalf Of Gustavo Correa
>>> Sent: 16 January 2012 23:54
>>> To: Open MPI Users
>>> Subject: Re: [OMPI users] localhost only
>>>
>>> Have you tried to specify the hosts with something like this?
>>>
>>> mpirun -np 2 -host localhost ./my_program
>>>
>>> See 'man mpirun' for more details.
>>>
>>> I hope it helps,
>>> Gus Correa
>>>
>>> On Jan 16, 2012, at 6:34 PM, MM wrote:
>>>
>>>> hi,
>>>>
>>>> when my wireless adapter is down on my laptop, only localhost is configured.
>>>> In this case, when I mpirun 2 binaries on my laptop, mpirun fails with this error:
>>>>
>>>>
>>>> It looks like orte_init failed for some reason; your parallel process i
>>>> likely to abort. There are many reasons that a parallel process can
>>>> fail during orte_init; some of which are due to configuration or
>>>> environment problems. This failure appears to be an internal failure;
>>>> here's some additional information (which may only be relevant to an
>>>> Open MPI developer):
>>>>
>>>> orte_rml_base_select failed
>>>> --> Returned value Error (-1) instead of ORTE_SUCCESS
>>>>
>>>>
>>>>
>>>> when I turn on the wireless adapter back on, the mpirun works fine
>>>>
>>>> Is there a way to make mpirun realize all my binaries run on the same box, and therefore don't need any other interface but localhost?
>>>>
>>>> PS: this is ipconfig when the wireless adapter is off
>>>>
>>>>> ipconfig /all
>>>>
>>>> Windows IP Configuration
>>>>
>>>> Host Name . . . . . . . . . . . . :
>>>> Primary Dns Suffix . . . . . . . :
>>>> Node Type . . . . . . . . . . . . : Hybrid
>>>> IP Routing Enabled. . . . . . . . : No
>>>> WINS Proxy Enabled. . . . . . . . : No
>>>>
>>>> Ethernet adapter Wireless Network Connection:
>>>>
>>>> Media State . . . . . . . . . . . : Media disconnected
>>>> Description . . . . . . . . . . . : Intel(R) WiFi Link 5100 AGN
>>>> Physical Address. . . . . . . . . :
>>>>
>>>> rds,
>>>>
>>>> MM
>>>> _______________________________________________
>>>> users mailing list
>>>> users_at_[hidden]
>>>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>>
>>>
>>> _______________________________________________
>>> users mailing list
>>> users_at_[hidden]
>>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>> _______________________________________________
>>> users mailing list
>>> users_at_[hidden]
>>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>
>>
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users