Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [OMPI users] localhost only
From: Ralph Castain (rhc.openmpi_at_[hidden])
Date: 2012-01-16 19:26:56


The problem is that OMPI is looking for a tcp port for your computer. With no network enabled, you don't have one, and so mpirun aborts. I don't know of any way around this at the moment.

Sent from my iPad

On Jan 16, 2012, at 4:53 PM, Gustavo Correa <gus_at_[hidden]> wrote:

> Have you tried to specify the hosts with something like this?
>
> mpirun -np 2 -host localhost ./my_program
>
> See 'man mpirun' for more details.
>
> I hope it helps,
> Gus Correa
>
> On Jan 16, 2012, at 6:34 PM, MM wrote:
>
>> hi,
>>
>> when my wireless adapter is down on my laptop, only localhost is configured.
>> In this case, when I mpirun 2 binaries on my laptop, mpirun fails with this error:
>>
>>
>> It looks like orte_init failed for some reason; your parallel process i
>> likely to abort. There are many reasons that a parallel process can
>> fail during orte_init; some of which are due to configuration or
>> environment problems. This failure appears to be an internal failure;
>> here's some additional information (which may only be relevant to an
>> Open MPI developer):
>>
>> orte_rml_base_select failed
>> --> Returned value Error (-1) instead of ORTE_SUCCESS
>>
>>
>>
>> when I turn on the wireless adapter back on, the mpirun works fine
>>
>> Is there a way to make mpirun realize all my binaries run on the same box, and therefore don't need any other interface but localhost?
>>
>> PS: this is ipconfig when the wireless adapter is off
>>
>>> ipconfig /all
>>
>> Windows IP Configuration
>>
>> Host Name . . . . . . . . . . . . :
>> Primary Dns Suffix . . . . . . . :
>> Node Type . . . . . . . . . . . . : Hybrid
>> IP Routing Enabled. . . . . . . . : No
>> WINS Proxy Enabled. . . . . . . . : No
>>
>> Ethernet adapter Wireless Network Connection:
>>
>> Media State . . . . . . . . . . . : Media disconnected
>> Description . . . . . . . . . . . : Intel(R) WiFi Link 5100 AGN
>> Physical Address. . . . . . . . . :
>>
>> rds,
>>
>> MM
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users