Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: [OMPI users] localhost only
From: MM (finjulhich_at_[hidden])
Date: 2012-01-16 18:34:56


hi,

 

when my wireless adapter is down on my laptop, only localhost is configured.

In this case, when I mpirun 2 binaries on my laptop, mpirun fails with this
error:

 

It looks like orte_init failed for some reason; your parallel process i

likely to abort. There are many reasons that a parallel process can

fail during orte_init; some of which are due to configuration or

environment problems. This failure appears to be an internal failure;

here's some additional information (which may only be relevant to an

Open MPI developer):

 

  orte_rml_base_select failed

  --> Returned value Error (-1) instead of ORTE_SUCCESS

 

 

 

when I turn on the wireless adapter back on, the mpirun works fine

 

Is there a way to make mpirun realize all my binaries run on the same box,
and therefore don't need any other interface but localhost?

 

PS: this is ipconfig when the wireless adapter is off

 

>ipconfig /all

 

Windows IP Configuration

 

        Host Name . . . . . . . . . . . . :

        Primary Dns Suffix . . . . . . . :

        Node Type . . . . . . . . . . . . : Hybrid

        IP Routing Enabled. . . . . . . . : No

        WINS Proxy Enabled. . . . . . . . : No

 

Ethernet adapter Wireless Network Connection:

 

        Media State . . . . . . . . . . . : Media disconnected

        Description . . . . . . . . . . . : Intel(R) WiFi Link 5100 AGN

        Physical Address. . . . . . . . . :

 

rds,

 

MM