Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Passwordless ssh
From: Mathieu westphal (mathieu.westphal_at_[hidden])
Date: 2011-12-20 04:45:12


Hello

You have to copy nodeX public key at the end of nodeY authorizedkeys.

Mathieu
Le 20/12/2011 05:03, Shaandar Nyamtulga a écrit :
> Hi
> I built Beuwolf cluster using OpenMPI reading the following link.
> http://techtinkering.com/2009/12/02/setting-up-a-beowulf-cluster-using-open-mpi-on-linux/
> I can access my nodes without password before mounting my slaves.
> But when I mount my slaves and run a program, it asks again passwords.
> |$eval `ssh-agent`
> |
> |$ssh-add ~/.ssh/id_dsa
>
> The above is not working. Terminal gives the reply "Could not open a connection to your authentication agent."
>
> Help is needed urgently.
>
> Thank you
>
> |
>
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users