Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Specifying GPU on mpi
From: Erin Rasmussen (erin.rasmussen_at_[hidden])
Date: 2011-12-12 16:10:05


This is a benchmarking project for the next couple of months because
we're building our GPU system at the moment. Right now I'm using HPL 2.0
from the site http://netlib.org/benchmark/hpl on our CPU only cluster. I
have the CUDA version from Nvidia downloaded for when our system is
running though. I just need to have a pretty good idea of how to run the
benchmark with GPUs because we would like to get into the Top 500. But
the main purpose of the system is for running research jobs, so we can't
spend too much time trying to figure out how to run HPL. I just thought
that the GPUs needed to be specified through the hostfile of mpirun, but
I guess I'm wrong. Since this isn't really an openmpi question, do you
know of any knowledge bases about HPL on GPUs?

On 12/12/2011 03:00 PM, Andreas Schäfer wrote:
> On 14:53 Mon 12 Dec , Erin Rasmussen wrote:
>> I have HPL working fine with openmpi using multiple nodes, but now
>> I'm trying to use it on our system with multiple nodes with CPUs and
>> GPUs.
> So this is an inquiry related to hpl, not Open MPI. Anyways, which
> version of HPL are you using and how would you specify the GPU to use
> sans MPI?
>
> Best
> -Andreas
>
>
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users