Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] EXTERNAL: Re: Unresolved reference 'mbind' and 'get_mempolicy'
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2011-12-08 15:12:58


On Sep 30, 2011, at 10:35 AM, Ed Blosch wrote:

> It IS the MPI application that is failing to link, not OpenMPI itself; my
> e-mail was not well written; sorry Brice.
>
> The situation is this: I am trying to compile using an OpenMPI 1.5.4 that
> was built to be rooted in /release, but it is not placed there yet
> (testing); it is currently under /builds/release. I have set OPAL_PREFIX in
> the environment, with the intention of helping the compiler wrappers work
> right. Under /release, I currently have OpenMPI 1.4.3, whereas the OpenMPI
> under /builds/release is 1.5.4.
>
> What I am getting is this: The mpif90 wrapper (under
> /builds/release/openmpi/bin) puts -I/release instead of -I/builds/release.
> But it includes -L/builds/release.

Can you tell me precisely how you built and installed OMPI, and then exactly how you're invoking mpif90?

E.g., are you doing a "make DESTDIR=/builds install" kind of installation?

-- 
Jeff Squyres
jsquyres_at_[hidden]
For corporate legal information go to:
http://www.cisco.com/web/about/doing_business/legal/cri/