Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] orte_ess_base_select failed
From: John Doe (javadevelopercl_at_[hidden])
Date: 2011-12-07 18:50:51


Thanks for all the suggestions. I'm able to get it to work now using the
simpler config line suggested. I did not fully explain my setup but it
turns out due to a mount error my machine was not seeing the new files in
the rebuilt openmpi directory which was remotely mounted, so I kept getting
the same errors :).

On Wed, Dec 7, 2011 at 1:30 PM, Ralph Castain <rhc_at_[hidden]> wrote:

>
> On Dec 7, 2011, at 10:45 AM, John Doe wrote:
>
> Ok. That did help a bit. I now see that the
> /opt/ompi/gnu/1.4.4/lib/openmpi/ directory has .so files as well as the .la
> files. Unfortunately I still get the same error when I run i.e it complains
> about missing files in that directory even though those files are present
> with an .so or .la extension (but not without):
> mca_parfinity_linux, mca_carto_auto_detect, mca_carto_file, mca_ess_env,
> mca_ess_hnp, mca_ess_singleton, mca_ess_slurm, mca_ess_tool
>
> Can anyone help with what these files are and how I can get my compile to
> generate them (without extensions)?
>
>
> I'm not sure why you would ever want to generate those files without their
> appropriate extensions - that's what the system is looking for. It sounds
> like everything is being built correctly, so the problem is just that you
> aren't finding them.
>
> I would check a couple of things. First, make sure that the "mpirun" you
> are executing is the one you think you are executing - i.e., do "which
> mpirun" to see that there isn't another one in the way.
>
> Second, check that you really do have the correct path in LD_LIBRARY_PATH
> and it isn't misspelled. I know you say you have it, but you'd be amazed
> how many times someone asks only to eventually find a typo.
>
>
>
>
> Thanks,
>
> Sam
>
>
>
> On Wed, Dec 7, 2011 at 11:19 AM, John Doe <javadevelopercl_at_[hidden]>wrote:
>
>> Hi Ralph,
>>
>> I may have been a little promiscous in my use of build flags. My initial
>> configure line was much simpler then I kept throwing in flags when it
>> wouldn't run. I'll try to build it again with the your config line and see
>> if that resolves the issue.
>>
>> Sam
>>
>>
>> On Wed, Dec 7, 2011 at 11:11 AM, Ralph Castain <rhc_at_[hidden]> wrote:
>>
>>> I don't understand your configure line - why did you give an argument to
>>> enable-shared?? That option doesn't take an argument, and may be causing
>>> the confusion. Also, enable-debug by default turns off optimization as
>>> otherwise the optimizer removes all debug symbols.
>>>
>>> If you want a debug version, try just this:
>>>
>>> ./configure --prefix=/opt/ompi/gnu/1.4.4 --enable-debug
>>> --with-valgrind=/opt/valgrind --enable-orterun-prefix-by-default
>>> --enable-memchecker --enable-mem-profile
>>>
>>> You don't need --with-devel-headers unless you intend to write code that
>>> directly drives the OMPI internals.
>>>
>>>
>>> On Dec 7, 2011, at 10:00 AM, John Doe wrote:
>>>
>>> Hi Gustavo,
>>>
>>> I do have /opt/ompi/gnu/1.4.4/lib in my LD_LIBRARY_PATH and the bin
>>> directory in my path as well but that didn't seem to help.
>>>
>>> Sam
>>>
>>> On Tue, Dec 6, 2011 at 5:18 PM, Gustavo Correa <gus_at_[hidden]>wrote:
>>>
>>>> Hi John Doe
>>>>
>>>> What you need to add to LD_LIBRARY_PATH is /opt/ompi/gnu/1.4.4/lib
>>>> [note 'lib' at the end].
>>>> Your email seems to say that you added /opt/ompi/gnu/1.4.4/lib/openmpi
>>>> instead, if I understood it right.
>>>> And to your PATH you need to add the corresponding 'bin' directory:
>>>> /opt/ompi/gnu/1.4.4/bin.
>>>> The rule here is your installation prefix /opt/ompi/gnu/1.4.4/
>>>> with 'lib' or 'bin' at the end.
>>>>
>>>> I hope this helps,
>>>> Frank Capra
>>>>
>>>> On Dec 6, 2011, at 5:54 PM, John Doe wrote:
>>>>
>>>> > I recently built and installed openmpi on my 64 bit linux machine
>>>> running centOS 6.
>>>> > However whenever I try mpirun I get the error message:
>>>> >
>>>> > [[INVALID],INVALID] ORTE_ERROR_LOG: Not found in file
>>>> runtime/orte_init.c at line 125
>>>> > orte_ess_base_select failed
>>>> >
>>>> > Actually here's the full error transcript:
>>>> >
>>>> ====================================================================================================
>>>> > >> mpiexec -n 4 object/a.out
>>>> > [ellipse:01480] mca: base: component_find: unable to open
>>>> /opt/ompi/gnu/1.4.4/lib/openmpi/mca_paffinity_linux: file not found
>>>> (ignored)
>>>> > [ellipse:01480] mca: base: component_find: unable to open
>>>> /opt/ompi/gnu/1.4.4/lib/openmpi/mca_carto_auto_detect: file not found
>>>> (ignored)
>>>> > [ellipse:01480] mca: base: component_find: unable to open
>>>> /opt/ompi/gnu/1.4.4/lib/openmpi/mca_carto_file: file not found (ignored)
>>>> > [ellipse:01480] mca: base: component_find: unable to open
>>>> /opt/ompi/gnu/1.4.4/lib/openmpi/mca_ess_env: file not found (ignored)
>>>> > [ellipse:01480] mca: base: component_find: unable to open
>>>> /opt/ompi/gnu/1.4.4/lib/openmpi/mca_ess_hnp: file not found (ignored)
>>>> > [ellipse:01480] mca: base: component_find: unable to open
>>>> /opt/ompi/gnu/1.4.4/lib/openmpi/mca_ess_singleton: file not found (ignored)
>>>> > [ellipse:01480] mca: base: component_find: unable to open
>>>> /opt/ompi/gnu/1.4.4/lib/openmpi/mca_ess_slurm: file not found (ignored)
>>>> > [ellipse:01480] mca: base: component_find: unable to open
>>>> /opt/ompi/gnu/1.4.4/lib/openmpi/mca_ess_tool: file not found (ignored)
>>>> > [ellipse:01480] [[INVALID],INVALID] ORTE_ERROR_LOG: Not found in file
>>>> runtime/orte_init.c at line 125
>>>> >
>>>> --------------------------------------------------------------------------
>>>> > It looks like orte_init failed for some reason; your parallel process
>>>> is
>>>> > likely to abort. There are many reasons that a parallel process can
>>>> > fail during orte_init; some of which are due to configuration or
>>>> > environment problems. This failure appears to be an internal failure;
>>>> > here's some additional information (which may only be relevant to an
>>>> > Open MPI developer):
>>>> >
>>>> > orte_ess_base_select failed
>>>> > --> Returned value Not found (-13) instead of ORTE_SUCCESS
>>>> >
>>>> --------------------------------------------------------------------------
>>>> >
>>>> >
>>>> =============================================================================================================
>>>> >
>>>> >
>>>> > Here are the configure options I used to build openmpi:
>>>> > ./configure --prefix=/opt/ompi/gnu/1.4.4 CC=gcc -m64 CXX=g++ -m64
>>>> FC=gfortran -m64 F77=gfortran -m64 CFLAGS=-O2 -g CXXFLAGS=-O2 -g
>>>> FCFLAGS=-O2 -g FFLAGS=-O2 -g --enable-debug --enable-shared=gcc
>>>> --with-valgrind=/opt/valgrind --with-devel-headers --enable-mem-profile
>>>> --enable-orterun-prefix-by-default --enable-memchecker
>>>> >
>>>> > Does anyone have any idea what these errors are. I tried recompiling
>>>> with the --enable-orterun-prefix-by-default flag. Also while those files
>>>> e.g mca_ess_tool are not found, the static versions e.g mca_ess_tool.a and
>>>> mca_ess_tool.la exist in the /opt/ompi/gnu/1.4.4/lib/openmpi
>>>> directory. I've also tried adding that directory to my LD_LIBRARY_PATH but
>>>> still get the same error. Help would be much appreciated.
>>>> >
>>>> > Thanks,
>>>> > Sam
>>>> > _______________________________________________
>>>> > users mailing list
>>>> > users_at_[hidden]
>>>> > http://www.open-mpi.org/mailman/listinfo.cgi/users
>>>>
>>>>
>>>> _______________________________________________
>>>> users mailing list
>>>> users_at_[hidden]
>>>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>>>
>>>
>>> _______________________________________________
>>> users mailing list
>>> users_at_[hidden]
>>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>>
>>>
>>>
>>> _______________________________________________
>>> users mailing list
>>> users_at_[hidden]
>>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>>
>>
>>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>