Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [OMPI users] orte_ess_base_select failed
From: tim (tprince_at_[hidden])
Date: 2011-12-07 14:50:33


------Original Message------
From: Gustavo Correa
Sender: users-bounces_at_[hidden]
To: Open MPI Users
ReplyTo: Open MPI Users
Sent: Dec 7, 2011 1:10 PM
Subject: Re: [OMPI users] orte_ess_base_select failed

Hi John Doe

I would keep it very simple, particularly if you are just starting with MPI or OpenMPI.
Why not this?

./configure --prefix=/opt/ompi/gnu/1.4.4

You may also point to the compilers CC, CXX, F77. FC, for C, C++, Fortran-77 and Fortran-90,
respectively , in case they are not in standard location.

Do a 'make distclean' before you start, to cleanup any old mess.

Once you get it working, you can add other flags.
However, I would add only those that you may really need.

I hope this helps,
Gary Cooper

On Dec 7, 2011, at 12:19 PM, John Doe wrote:

> Hi Ralph,
>
> I may have been a little promiscous in my use of build flags. My initial configure line was much simpler then I kept throwing in flags when it wouldn't run. I'll try to build it again with the your config line and see if that resolves the issue.
>
> Sam
>
> On Wed, Dec 7, 2011 at 11:11 AM, Ralph Castain <rhc_at_[hidden]> wrote:
> I don't understand your configure line - why did you give an argument to enable-shared?? That option doesn't take an argument, and may be causing the confusion. Also, enable-debug by default turns off optimization as otherwise the optimizer removes all debug symbols.
>
> If you want a debug version, try just this:
>
> ./configure --prefix=/opt/ompi/gnu/1.4.4 --enable-debug --with-valgrind=/opt/valgrind --enable-orterun-prefix-by-default --enable-memchecker --enable-mem-profile
>
> You don't need --with-devel-headers unless you intend to write code that directly drives the OMPI internals.
>
>
> On Dec 7, 2011, at 10:00 AM, John Doe wrote:
>
>> Hi Gustavo,
>>
>> I do have /opt/ompi/gnu/1.4.4/lib in my LD_LIBRARY_PATH and the bin directory in my path as well but that didn't seem to help.
>>
>> Sam
>>
>> On Tue, Dec 6, 2011 at 5:18 PM, Gustavo Correa <gus_at_[hidden]> wrote:
>> Hi John Doe
>>
>> What you need to add to LD_LIBRARY_PATH is /opt/ompi/gnu/1.4.4/lib
>> [note 'lib' at the end].
>> Your email seems to say that you added /opt/ompi/gnu/1.4.4/lib/openmpi
>> instead, if I understood it right.
>> And to your PATH you need to add the corresponding 'bin' directory:
>> /opt/ompi/gnu/1.4.4/bin.
>> The rule here is your installation prefix /opt/ompi/gnu/1.4.4/
>> with 'lib' or 'bin' at the end.
>>
>> I hope this helps,
>> Frank Capra
>>
>> On Dec 6, 2011, at 5:54 PM, John Doe wrote:
>>
>> > I recently built and installed openmpi on my 64 bit linux machine running centOS 6.
>> > However whenever I try mpirun I get the error message:
>> >
>> > [[INVALID],INVALID] ORTE_ERROR_LOG: Not found in file runtime/orte_init.c at line 125
>> > orte_ess_base_select failed
>> >
>> > Actually here's the full error transcript:
>> > ====================================================================================================
>> > >> mpiexec -n 4 object/a.out
>> > [ellipse:01480] mca: base: component_find: unable to open /opt/ompi/gnu/1.4.4/lib/openmpi/mca_paffinity_linux: file not found (ignored)
>> > [ellipse:01480] mca: base: component_find: unable to open /opt/ompi/gnu/1.4.4/lib/openmpi/mca_carto_auto_detect: file not found (ignored)
>> > [ellipse:01480] mca: base: component_find: unable to open /opt/ompi/gnu/1.4.4/lib/openmpi/mca_carto_file: file not found (ignored)
>> > [ellipse:01480] mca: base: component_find: unable to open /opt/ompi/gnu/1.4.4/lib/openmpi/mca_ess_env: file not found (ignored)
>> > [ellipse:01480] mca: base: component_find: unable to open /opt/ompi/gnu/1.4.4/lib/openmpi/mca_ess_hnp: file not found (ignored)
>> > [ellipse:01480] mca: base: component_find: unable to open /opt/ompi/gnu/1.4.4/lib/openmpi/mca_ess_singleton: file not found (ignored)
>> > [ellipse:01480] mca: base: component_find: unable to open /opt/ompi/gnu/1.4.4/lib/openmpi/mca_ess_slurm: file not found (ignored)
>> > [ellipse:01480] mca: base: component_find: unable to open /opt/ompi/gnu/1.4.4/lib/openmpi/mca_ess_tool: file not found (ignored)
>> > [ellipse:01480] [[INVALID],INVALID] ORTE_ERROR_LOG: Not found in file runtime/orte_init.c at line 125
>>

Sent via BlackBerry by AT&T