Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] orte_ess_base_select failed
From: Gustavo Correa (gus_at_[hidden])
Date: 2011-12-07 13:18:33


Hi John Doe

Set these environment variables in your .profile/.bashrc or .[t]cshrc file.
If you set them in the shell prompt, before you run the job, I am not sure they will
propagate to the MPI processes, even if you are running in a standalone machine
[which apparently you are].
Ralph may clarify this point about the environment variables' inheritance.

Alternatively, you could also pass the environment variables to the processes in the mpiexec command line, e.g. [in bash]:

export LD_LIBRARY_PATH=whatever
export PATH=whaever_else
mpiexec -x LD_LIBRARY_PATH -x PATH -np=4 ./my_program.

I hope this helps,
Edward Arnold

On Dec 7, 2011, at 12:00 PM, John Doe wrote:

> Hi Gustavo,
>
> I do have /opt/ompi/gnu/1.4.4/lib in my LD_LIBRARY_PATH and the bin directory in my path as well but that didn't seem to help.
>
> Sam
>
> On Tue, Dec 6, 2011 at 5:18 PM, Gustavo Correa <gus_at_[hidden]> wrote:
> Hi John Doe
>
> What you need to add to LD_LIBRARY_PATH is /opt/ompi/gnu/1.4.4/lib
> [note 'lib' at the end].
> Your email seems to say that you added /opt/ompi/gnu/1.4.4/lib/openmpi
> instead, if I understood it right.
> And to your PATH you need to add the corresponding 'bin' directory:
> /opt/ompi/gnu/1.4.4/bin.
> The rule here is your installation prefix /opt/ompi/gnu/1.4.4/
> with 'lib' or 'bin' at the end.
>
> I hope this helps,
> Frank Capra
>
> On Dec 6, 2011, at 5:54 PM, John Doe wrote:
>
> > I recently built and installed openmpi on my 64 bit linux machine running centOS 6.
> > However whenever I try mpirun I get the error message:
> >
> > [[INVALID],INVALID] ORTE_ERROR_LOG: Not found in file runtime/orte_init.c at line 125
> > orte_ess_base_select failed
> >
> > Actually here's the full error transcript:
> > ====================================================================================================
> > >> mpiexec -n 4 object/a.out
> > [ellipse:01480] mca: base: component_find: unable to open /opt/ompi/gnu/1.4.4/lib/openmpi/mca_paffinity_linux: file not found (ignored)
> > [ellipse:01480] mca: base: component_find: unable to open /opt/ompi/gnu/1.4.4/lib/openmpi/mca_carto_auto_detect: file not found (ignored)
> > [ellipse:01480] mca: base: component_find: unable to open /opt/ompi/gnu/1.4.4/lib/openmpi/mca_carto_file: file not found (ignored)
> > [ellipse:01480] mca: base: component_find: unable to open /opt/ompi/gnu/1.4.4/lib/openmpi/mca_ess_env: file not found (ignored)
> > [ellipse:01480] mca: base: component_find: unable to open /opt/ompi/gnu/1.4.4/lib/openmpi/mca_ess_hnp: file not found (ignored)
> > [ellipse:01480] mca: base: component_find: unable to open /opt/ompi/gnu/1.4.4/lib/openmpi/mca_ess_singleton: file not found (ignored)
> > [ellipse:01480] mca: base: component_find: unable to open /opt/ompi/gnu/1.4.4/lib/openmpi/mca_ess_slurm: file not found (ignored)
> > [ellipse:01480] mca: base: component_find: unable to open /opt/ompi/gnu/1.4.4/lib/openmpi/mca_ess_tool: file not found (ignored)
> > [ellipse:01480] [[INVALID],INVALID] ORTE_ERROR_LOG: Not found in file runtime/orte_init.c at line 125
> > --------------------------------------------------------------------------
> > It looks like orte_init failed for some reason; your parallel process is
> > likely to abort. There are many reasons that a parallel process can
> > fail during orte_init; some of which are due to configuration or
> > environment problems. This failure appears to be an internal failure;
> > here's some additional information (which may only be relevant to an
> > Open MPI developer):
> >
> > orte_ess_base_select failed
> > --> Returned value Not found (-13) instead of ORTE_SUCCESS
> > --------------------------------------------------------------------------
> >
> > =============================================================================================================
> >
> >
> > Here are the configure options I used to build openmpi:
> > ./configure --prefix=/opt/ompi/gnu/1.4.4 CC=gcc -m64 CXX=g++ -m64 FC=gfortran -m64 F77=gfortran -m64 CFLAGS=-O2 -g CXXFLAGS=-O2 -g FCFLAGS=-O2 -g FFLAGS=-O2 -g --enable-debug --enable-shared=gcc --with-valgrind=/opt/valgrind --with-devel-headers --enable-mem-profile --enable-orterun-prefix-by-default --enable-memchecker
> >
> > Does anyone have any idea what these errors are. I tried recompiling with the --enable-orterun-prefix-by-default flag. Also while those files e.g mca_ess_tool are not found, the static versions e.g mca_ess_tool.a and mca_ess_tool.la exist in the /opt/ompi/gnu/1.4.4/lib/openmpi directory. I've also tried adding that directory to my LD_LIBRARY_PATH but still get the same error. Help would be much appreciated.
> >
> > Thanks,
> > Sam
> > _______________________________________________
> > users mailing list
> > users_at_[hidden]
> > http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users