Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: [OMPI users] Open MPI and DAPL 2.0.34 are incompatible?
From: Paul Kapinos (kapinos_at_[hidden])
Date: 2011-12-02 13:21:23


Dear Open MPI developer,

OFED 1.5.4 will contain DAPL 2.0.34.

I tried to compile the newest release of Open MPI (1.5.4) with this DAPL
release and I was not successful.

Configuring with --with-udapl=/path/to/2.0.34/dapl
got the error "/path/to/2.0.34/dapl/include/dat/udat.h not found"
Looking into include dir: there is no 'dat' subdir but 'dat2'.

Just for fun I also tried to move 'dat2' to 'dat' back (dirty hack I
know :-) - the configure stage was then successful but the compilation
failed. The header seem to be really changed, not just moved.

The question: are the Open MPI developer aware of this changes, and when
a version of Open MPI will be available with support for DAPL 2.0.34?

(Background: we have some trouble with Intel MPI and current DAPL which
we do not have with DAPL 2.0.34, so our dream is to update as soon as
possible)

Best wishes and an nice weekend,

Paul

http://www.openfabrics.org/downloads/OFED/release_notes/OFED_1.5.4_release_notes

-- 
Dipl.-Inform. Paul Kapinos   -   High Performance Computing,
RWTH Aachen University, Center for Computing and Communication
Seffenter Weg 23,  D 52074  Aachen (Germany)
Tel: +49 241/80-24915