Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] orte_debugger_select and orte_ess_set_name failed
From: MM (finjulhich_at_[hidden])
Date: 2011-11-29 09:50:16


fantastic, thank you very much,

-----Original Message-----
From: Shiqing Fan [mailto:fan_at_[hidden]]
Sent: 29 November 2011 14:10
To: MM
Cc: 'Open MPI Users'
Subject: Re: [OMPI users] orte_debugger_select and orte_ess_set_name failed

Hi MM,

That doesn't really help.

Do you need a debug version on your 32 bit Windows XP? Maybe I can build
one for you. Will send it to you off the mailing list.

Regards,
Shiqing

On 2011-11-29 2:59 PM, MM wrote:
> debugging mpirund arrives to
> openmpi-1.5.4\opal\mca\base\mca_base_components_select.c:
> function mca_base_select
>
> components_available list appears to be empty, ie
> orte_debugger_base_components_available appears to be empty (opal list
> length=0)
>
> Is this an indication of something meaningful?
>
> Note, I built opnempi static libs (with dll c/c++ runtime)
> OMPI_IMPORTS is __not__ defined, that's how I got it to compile
>
> MM
> -----Original Message-----
> From: Shiqing Fan [mailto:fan_at_[hidden]]
> Sent: 25 November 2011 22:19
> To: MM
> Subject: Re: [OMPI users] orte_debugger_select and orte_ess_set_name
failed
>
> Hi MM,
>
> Do you really want to build Open MPI by yourself? If you only need the
> libraries, probably you may stick to 1.5.4 binaries, which you said
> works for you.
>
> Anyway, if you want to debug mpirun, you can step into orterun project,
> which generates mpirun executable.
>
> Which version of Open MPI are you building? I'm not sure whether I'll
> have time this days to look closely to this problem, but if you can
> reproduce this problem with a small test program, and send it to me, I
> would like also help debug it.
>
>
> Best Regards,
> Shiqing
>
>
> On 2011-11-25 11:06 PM, MM wrote:
>> Shiqing,
>>
>> As I built the mpi libs in debug as well, can I break point somehow when
I
>> run
>>
>> mpirun -np 1<debugbinary1> : -np 1<debugbinary2>
>>
>> and I get those 2 errors.
>>
>> Can I breakpoint somehow inside vs2010? maybe to investigate what's going
>> on?
>>
>> How do I launch "mpirun" in debug from the openmpi solution. Which
project
>> generates the mpirun binary?
>>
>> I am a bit stuck and would appreciate help to progress,
>>
>> rds,
>>
>> MM
>>
>> -----Original Message-----
>> From: Shiqing Fan [mailto:fan_at_[hidden]]
>> Sent: 24 November 2011 16:44
>> To: MM
>> Cc: 'Open MPI Users'
>> Subject: Re: [OMPI users] orte_debugger_select and orte_ess_set_name
> failed
>> Hi MM,
>>
>> Sorry for the delayed reply, I was busy in a meeting these days.
>>
>> The log files seem not very helpful to solve the problem. May be your
>> CMakeCache.txt file would help.
>>
>> Currently we don't provided binaries built from trunk. Have you also
>> tried the 1.5.x binaries?
>>
>> Best Regards,
>> Shiqing
>>
>> On 2011-11-23 10:08 PM, MM wrote:
>>> Hi Shiqing,
>>>
>>> Is the info provided useful to understand what's going on?
>>> Alternatively, is there a way to get the provided binaries for win but
> off
>>> trunk rather than off 1.5.4 as on the website, because I don't have this
>>> problem when I link against those libs,
>>>
>>> Thanks
>>>
>>> MM
>>>
>>> -----Original Message-----
>>> From: users-bounces_at_[hidden] [mailto:users-bounces_at_[hidden]] On
>>> Behalf Of MM
>>> Sent: 21 November 2011 21:08
>>> To: fan_at_[hidden]
>>> Cc: 'Open MPI Users'
>>> Subject: Re: [OMPI users] orte_debugger_select and orte_ess_set_name
>> failed
>>> Hi,
>>>
>>> I have placed the source in \Program Files\openmpi-1.5.4 the build dir
in
>>> \Program Files\openmpi.build and the install dir in \Program
> Files\openmpi
>>> I could not find config.log in any of the 3 directories nor in the
>> directory
>>> from which I run mpirun.
>>>
>>> The build log attached is a zip of all the .log under \Program
>>> Files\openmpi.build
>>>
>>> First, I installed the provided binaries on xp32bit, and successfully
ran
>>> the program in Release mode.
>>> in debug mode, there was that error of some function missing in kernel,
>> that
>>> you fixed in svn.
>>>
>>> Second, I then downloaded the source and built the static libraries w
>> cmake
>>> according to README.windows, and against these home built libs, the same
>>> program run neithers in debug nor in release, because of the error
below.
>>>
>>> How can I generate the config.log?
>>>
>>> About Debug/Release, thinking about it at this time, I don't really need
>> the
>>> debug libs of openmpi.
>>> but to be able to link against vs2010 Release libs of openmpi, I need
> them
>>> to be linked against the Release c runtime, so I might as well link
>> against
>>> the debug version of the openmpi libs.
>>>
>>> Your help is very appreciated,
>>> MM
>>>
>>> -----Original Message-----
>>> From: Shiqing Fan [mailto:fan_at_[hidden]]
>>> Sent: 21 November 2011 12:48
>>> To: Open MPI Users
>>> Cc: MM
>>> Subject: Re: [OMPI users] orte_debugger_select and orte_ess_set_name
>> failed
>>> Hi,
>>>
>>> Could you please send your config and build log to me? Have you tried
> with
>> a
>>> simpler program? Does this error always happen?
>>>
>>> Regards,
>>> Shiqing
>>>
>>>
>>> On 2011-11-19 4:24 PM, MM wrote:
>>>> Trying to run my program linked against debug 1.5.4 on vs2010 fails:
>>>>
>>>>>>> mpirun -np 1 .\nhui\Debug\nhui.exe : -np 1
>>>>>>> .\nhcomp\Debug\nhcomp.exe
>>>> [PCNAME:04960] [[1282,0],0] ORTE_ERROR_LOG: Not found in file
>>>> C:\Program Files\openmpi-1.5.4\orte\mca\ess\hnp\ess_hnp_module.c at
>>>> line 536
>>>> ----------------------------------------------------------------------
>>>> ---- It looks like orte_init failed for some reason; your parallel
>>>> process is likely to abort. There are many reasons that a parallel
>>>> process can fail during orte_init; some of which are due to
>>>> configuration or environment problems. This failure appears to be an
>>>> internal failure; here's some additional information (which may only
>>>> be relevant to an Open MPI developer):
>>>>
>>>> orte_debugger_select failed
>>>> --> Returned value Not found (-13) instead of ORTE_SUCCESS
>>>> ----------------------------------------------------------------------
>>>> ---- [PCNAME:04960] [[1282,0],0] ORTE_ERROR_LOG: Not found in file
>>>> C:\Program Files\openmpi-1.5.4\orte\runtime\orte_init.c at line 128
>>>> ----------------------------------------------------------------------
>>>> ---- It looks like orte_init failed for some reason; your parallel
>>>> process is likely to abort. There are many reasons that a parallel
>>>> process can fail during orte_init; some of which are due to
>>>> configuration or environment problems. This failure appears to be an
>>>> internal failure; here's some additional information (which may only
>>>> be relevant to an Open MPI developer):
>>>>
>>>> orte_ess_set_name failed
>>>> --> Returned value Not found (-13) instead of ORTE_SUCCESS
>>>> ----------------------------------------------------------------------
>>>> ---- [LLDNRATDHY9H4J:04960] [[1282,0],0] ORTE_ERROR_LOG: Not found in
>>>> file C:\Program Files\openmpi-1.5.4\orte\tools\orterun\orterun.c at
>>>> line 616
>>>>
>>>> any help is appreciated,
>>>> MM
>>>>
>>>> _______________________________________________
>>>> users mailing list
>>>> users_at_[hidden]
>>>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>>>
>>> --
>>> ---------------------------------------------------------------
>>> Shiqing Fan
>>> High Performance Computing Center Stuttgart (HLRS)
>>> Tel: ++49(0)711-685-87234 Nobelstrasse 19
>>> Fax: ++49(0)711-685-65832 70569 Stuttgart
>>> http://www.hlrs.de/organization/people/shiqing-fan/
>>> email: fan_at_[hidden]
>>>
>>>
>>>
>
****************************************************************************
>>> *
>>> **
>>> **
>>> ** WARNING: This email contains an attachment of a very suspicious
type.
>>> **
>>> ** You are urged NOT to open this attachment unless you are absolutely
>>> **
>>> ** sure it is legitimate. Opening this attachment may cause irreparable
>>> **
>>> ** damage to your computer and your files. If you have any questions
>>> **
>>> ** about the validity of this message, PLEASE SEEK HELP BEFORE OPENING
> IT.
>>> **
>>> **
>>> **
>>> ** This warning was added by the IU Computer Science Dept. mail scanner.
>>> **
>>>
>
****************************************************************************
>>> *
>>>
>>>
>>>
>>>
>

-- 
---------------------------------------------------------------
Shiqing Fan
High Performance Computing Center Stuttgart (HLRS)
Tel: ++49(0)711-685-87234      Nobelstrasse 19
Fax: ++49(0)711-685-65832      70569 Stuttgart
http://www.hlrs.de/organization/people/shiqing-fan/
email: fan_at_[hidden]