Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] orte_debugger_select and orte_ess_set_name failed
From: MM (finjulhich_at_[hidden])
Date: 2011-11-21 16:08:13


Hi,

I have placed the source in \Program Files\openmpi-1.5.4
the build dir in \Program Files\openmpi.build
and the install dir in \Program Files\openmpi

I could not find config.log in any of the 3 directories nor in the directory
from which I run mpirun.

The build log attached is a zip of all the .log under \Program
Files\openmpi.build

First, I installed the provided binaries on xp32bit, and successfully ran
the program in Release mode.
in debug mode, there was that error of some function missing in kernel, that
you fixed in svn.

Second, I then downloaded the source and built the static libraries w cmake
according to README.windows, and against these home built libs, the same
program run neithers in debug nor in release, because of the error below.

How can I generate the config.log?

About Debug/Release, thinking about it at this time, I don't really need the
debug libs of openmpi.
but to be able to link against vs2010 Release libs of openmpi, I need them
to be linked against the Release c runtime, so I might as well link against
the debug version of the openmpi libs.

Your help is very appreciated,
MM

-----Original Message-----
From: Shiqing Fan [mailto:fan_at_[hidden]]
Sent: 21 November 2011 12:48
To: Open MPI Users
Cc: MM
Subject: Re: [OMPI users] orte_debugger_select and orte_ess_set_name failed

Hi,

Could you please send your config and build log to me? Have you tried
with a simpler program? Does this error always happen?

Regards,
Shiqing

On 2011-11-19 4:24 PM, MM wrote:
> Trying to run my program linked against debug 1.5.4 on vs2010 fails:
>
>>>> mpirun -np 1 .\nhui\Debug\nhui.exe : -np 1 .\nhcomp\Debug\nhcomp.exe
> [PCNAME:04960] [[1282,0],0] ORTE_ERROR_LOG: Not found in file C:\Program
> Files\openmpi-1.5.4\orte\mca\ess\hnp\ess_hnp_module.c at line 536
> --------------------------------------------------------------------------
> It looks like orte_init failed for some reason; your parallel process is
> likely to abort. There are many reasons that a parallel process can
> fail during orte_init; some of which are due to configuration or
> environment problems. This failure appears to be an internal failure;
> here's some additional information (which may only be relevant to an
> Open MPI developer):
>
> orte_debugger_select failed
> --> Returned value Not found (-13) instead of ORTE_SUCCESS
> --------------------------------------------------------------------------
> [PCNAME:04960] [[1282,0],0] ORTE_ERROR_LOG: Not found in file C:\Program
> Files\openmpi-1.5.4\orte\runtime\orte_init.c at line 128
> --------------------------------------------------------------------------
> It looks like orte_init failed for some reason; your parallel process is
> likely to abort. There are many reasons that a parallel process can
> fail during orte_init; some of which are due to configuration or
> environment problems. This failure appears to be an internal failure;
> here's some additional information (which may only be relevant to an
> Open MPI developer):
>
> orte_ess_set_name failed
> --> Returned value Not found (-13) instead of ORTE_SUCCESS
> --------------------------------------------------------------------------
> [LLDNRATDHY9H4J:04960] [[1282,0],0] ORTE_ERROR_LOG: Not found in file
> C:\Program Files\openmpi-1.5.4\orte\tools\orterun\orterun.c at line 616
>
> any help is appreciated,
> MM
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>

-- 
---------------------------------------------------------------
Shiqing Fan
High Performance Computing Center Stuttgart (HLRS)
Tel: ++49(0)711-685-87234      Nobelstrasse 19
Fax: ++49(0)711-685-65832      70569 Stuttgart
http://www.hlrs.de/organization/people/shiqing-fan/
email: fan_at_[hidden]
*****************************************************************************
**                                                                         **
** WARNING:  This email contains an attachment of a very suspicious type.  **
** You are urged NOT to open this attachment unless you are absolutely     **
** sure it is legitimate.  Opening this attachment may cause irreparable   **
** damage to your computer and your files.  If you have any questions      **
** about the validity of this message, PLEASE SEEK HELP BEFORE OPENING IT. **
**                                                                         **
** This warning was added by the IU Computer Science Dept. mail scanner.   **
*****************************************************************************