Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Is it not possible to run a program with MPI code without mpirun/mpiexec?
From: Ralph Castain (rhc_at_[hidden])
Date: 2011-11-14 07:45:59


Hmmm...it -should- work, but I've never tried it on Windows. I will verify it under Linux, but will have to defer to Shiqing to see if there is something particular about the Windows environment.

On Nov 13, 2011, at 8:13 PM, Naor Movshovitz wrote:

> I have open-mpi v1.5.4, installed from the binary installer for
> Windows. The following program test.c
>
> #include <stdio.h>
> #include <mpi.h>
> int main(int argc, char *argv[])
> {
> int rank, size;
> MPI_Init(&argc,&argv);
> MPI_Comm_size(MPI_COMM_WORLD,&size);
> MPI_Comm_rank(MPI_COMM_WORLD,&rank);
> printf("hellow world from rank %d of %d.\n",rank,size);
> MPI_Finalize();
> return 0;
> }
>
> is compiled and linked without issue with
>
> c:\temp\mpicc test.c
>
> It also runs without issue with
>
> c:\temp\mpirun test.exe
>
> and prints the expected output. However, running the executable directly, as in
>
> c:\temp\test
>
> prints the following and then hangs:
>
> [COMPUTERNAME:03060] [[34061,0],0] ORTE_ERROR_LOG: Value out of
> bounds in file ../../../openmpi-1.5.4\orte\mca\oob\tcp\oob_tcp.c at
> line 1193
>
> Is this a bug? I normally expect mpi programs to run without problem
> as a standalone executable. I should add that the mpi installation
> does not have any directories/files named in the error log, only
> pre-built binaries.
>
> Thanks muchly,
> -nuun
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users