Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [OMPI users] Problem with openmpi-default-hostfile
From: Lukas Razik (linux_at_[hidden])
Date: 2011-11-07 05:07:31


Hello Ralph and thanks for your answer!

> Where did you install OMPI? If you check "which mpirun", does it point
> to the same installation where you edited the default hostfile?

It was installed in the default path which is chosen by OFED.
And yes, I've edited the right openmpi-default-hostfile :

$ which mpirun
/usr/mpi/gcc/openmpi-1.4.3/bin/mpirun

$ cat /usr/mpi/gcc/openmpi-1.4.3/etc/openmpi-default-hostfile
cluster1
cluster2
cluster3
cluster4

$ mpirun -np 4 B4A1
Hello World! I am rank 003 of 4 on hostname=cluster1.
Hello World! I am rank 000 of 4 on hostname=cluster1.
Hello World! I am rank 002 of 4 on hostname=cluster1.
Hello World! I am rank 001 of 4 on hostname=cluster1.

$ mpirun -hostfile /usr/mpi/gcc/openmpi-1.4.3/etc/openmpi-default-hostfile -np 4 B4A1
Hello World! I am rank 000 of 4 on hostname=cluster1.
Hello World! I am rank 001 of 4 on hostname=cluster2.
Hello World! I am rank 002 of 4 on hostname=cluster3.
Hello World! I am rank 003 of 4 on hostname=cluster4.

Regards,
Lukas