Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [OMPI users] Changing plm_rsh_agent system wide
From: TERRY DONTJE (terry.dontje_at_[hidden])
Date: 2011-10-26 10:51:06


Sorry please disregard my reply to this email.

:-)

--td

On 10/26/2011 10:44 AM, Ralph Castain wrote:
> Did the version you are running get installed in /usr? Sounds like you are picking up a different version when running a command - i.e., that your PATH is finding a different installation than the one in /usr.
>
>
> On Oct 26, 2011, at 3:11 AM, Patrick Begou wrote:
>
>> I need to change system wide how OpenMPI launch the jobs on the nodes of my cluster.
>>
>> Setting:
>> export OMPI_MCA_plm_rsh_agent=oarsh
>>
>> works fine but I would like this config to be the default with OpenMPI. I've read several threads (discussions, FAQ) about this but none of the provided solutions seams to work.
>>
>> I have two files:
>> /usr/lib/openmpi/1.4-gcc/etc/openmpi-mca-params.conf
>> /usr/lib64/openmpi/1.4-gcc/etc/openmpi-mca-params.conf
>>
>> In these files I've set various flavor of the syntax (only one at a time, and the same in each file of course!):
>> test 1) plm_rsh_agent = oarsh
>> test 2) pls_rsh_agent = oarsh
>> test 3) orte_rsh_agent = oarsh
>>
>> But each time when I run "ompi_info --param plm rsh" I get:
>> MCA plm: parameter "plm_rsh_agent" (current value: "ssh : rsh", data source: default value, synonyms:
>> pls_rsh_agent)
>> The command used to launch executables on remote nodes (typically either "ssh" or "rsh")
>>
>> With the exported variable it works fine.
>> Any suggestion ?
>>
>> The rpm package of my linux Rocks Cluster provides:
>> Package: Open MPI root_at_build-x86-64 Distribution
>> Open MPI: 1.4.3
>> Open MPI SVN revision: r23834
>> Open MPI release date: Oct 05, 2010
>>
>> Thanks
>>
>> Patrick
>>
>>
>>
>> --
>> ===============================================================
>> | Equipe M.O.S.T. | http://most.hmg.inpg.fr |
>> | Patrick BEGOU | ------------ |
>> | LEGI | mailto:Patrick.Begou_at_[hidden] |
>> | BP 53 X | Tel 04 76 82 51 35 |
>> | 38041 GRENOBLE CEDEX | Fax 04 76 82 52 71 |
>> ===============================================================
>>
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Oracle
Terry D. Dontje | Principal Software Engineer
Developer Tools Engineering | +1.781.442.2631
Oracle *- Performance Technologies*
95 Network Drive, Burlington, MA 01803
Email terry.dontje_at_[hidden] <mailto:terry.dontje_at_[hidden]>



picture