Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: [OMPI users] Changing plm_rsh_agent system wide
From: Patrick Begou (Patrick.Begou_at_[hidden])
Date: 2011-10-26 05:11:08


I need to change system wide how OpenMPI launch the jobs on the nodes of my cluster.

Setting:
export OMPI_MCA_plm_rsh_agent=oarsh

works fine but I would like this config to be the default with OpenMPI. I've
read several threads (discussions, FAQ) about this but none of the provided
solutions seams to work.

I have two files:
/usr/lib/openmpi/1.4-gcc/etc/openmpi-mca-params.conf
/usr/lib64/openmpi/1.4-gcc/etc/openmpi-mca-params.conf

In these files I've set various flavor of the syntax (only one at a time, and
the same in each file of course!):
test 1) plm_rsh_agent = oarsh
test 2) pls_rsh_agent = oarsh
test 3) orte_rsh_agent = oarsh

But each time when I run "ompi_info --param plm rsh" I get:
MCA plm: parameter "plm_rsh_agent" (current value: "ssh : rsh", data source:
default value, synonyms:
                   pls_rsh_agent)
                   The command used to launch executables on remote nodes
(typically either "ssh" or "rsh")

With the exported variable it works fine.
Any suggestion ?

The rpm package of my linux Rocks Cluster provides:
    Package: Open MPI root_at_build-x86-64 Distribution
    Open MPI: 1.4.3
    Open MPI SVN revision: r23834
    Open MPI release date: Oct 05, 2010

Thanks

Patrick

  --
===============================================================
| Equipe M.O.S.T. | http://most.hmg.inpg.fr |
| Patrick BEGOU | ------------ |
| LEGI | mailto:Patrick.Begou_at_[hidden] |
| BP 53 X | Tel 04 76 82 51 35 |
| 38041 GRENOBLE CEDEX | Fax 04 76 82 52 71 |
===============================================================