Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] problem running with RoCE over 10GbE
From: Yevgeny Kliteynik (kliteyn_at_[hidden])
Date: 2011-10-05 09:35:29


On 05-Oct-11 3:15 PM, Jeff Squyres wrote:
>> You shouldn't use the "--enable-openib-rdmacm" option - rdmacm
>> support is enabled by default, providing librdmacm is found on
>> the machine.
>
> Actually, this might be a configure bug. We have lots of other configure options that, even if "foo" support is optional, if you specify "--with-foo", then OMPI treats it as mandatory. Specifically, if foo can't be found, it's an error and configure should abort (i.e., let a human figure it out).
>
> Yevgeny -- can you check that out?

Yep, indeed - configure doesn't abort when "--enable-openib-rdmacm"
is provided and "rdma/rdma_cma.h" is not found.

-- YK

 
>> So the question is, why OMPI config script didn't find it?
>> OMPI looks for "rdma/rdma_cma.h" header. Do you have it on
>> you build machine?
>> The usual location of this file is /usr/include/rdma/rdma_cma.h
>
> Here's the culprit in config.log:
>
> configure:118771: checking rdma/rdma_cma.h presence
> configure:118771: gcc -E conftest.c
> conftest.c:573:27: error: rdma/rdma_cma.h: No such file or directory
> configure:118771: $? = 1
>
> I'd double check that that file is actually present on your system. I don't think<> vs. "" will make a difference, though.
>