Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Non-continous ranks with "--np 4 -npernode 3 -bynode"
From: Ralph Castain (rhc.openmpi_at_[hidden])
Date: 2011-10-04 10:54:17


Looks like a bug - can address next week. Very unusual use of npernode...

Sent from my iPad

On Oct 4, 2011, at 4:55 AM, Andrew Senin <andrew.senin_at_[hidden]> wrote:

> Hi all,
>
> I noticed a strange behaviour in 1.5.4 which seems to me as a bug. I'm trying to launch 4 ranks on 2 nodes. If I add "-npernode 3 -bynode" parameters mpirun freezes on start. When I tried with the "-display-map" parameter it shows the following:
> ./mpirun --np 4 --host mir1,mir2 -npernode 3 -display-map -bynode ./hello
>
> ======================== JOB MAP ========================
>
> Data for node: mir1 Num procs: 3
> Process OMPI jobid: [42759,1] Process rank: 0
> Process OMPI jobid: [42759,1] Process rank: 2
> Process OMPI jobid: [42759,1] Process rank: 4
>
> Data for node: mir2 Num procs: 1
> Process OMPI jobid: [42759,1] Process rank: 1
>
> Which seems as a problem since there supposed to be no rank #4 as np=4.
>
> I've also tried with trunk. The application also freezes but does not show the map of ranks.
>
> Could you please assist if this is a bug or I'm doing something improperly?
>
> Regards,
> Andrew Senin
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users