Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [OMPI users] Trouble compiling 1.4.3 with PGI 10.9 compilers
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2011-09-24 09:23:27


Just out of curiosity, does Open MPI 1.5.4 build properly?

We've seen problems with the PGI compiler suite before -- it *does* look like a problem with libtool-building issues; e.g., a switch is too old or is missing or something. Meaning: it looks like PGI thinks it's trying to build an application, not a library. This is usually bit rot in libtool (i.e., PGI may have changed their options, but we're using an older Libtool in the 1.4.x series that doesn't know about this option).

I do note that we fixed some libtool issues in the 1.4.4 tarball; could you try the 1.4.4rc and see if that fixes the issue? If not, we might have missed some patches to bring over to the v1.4 branch.

    http://www.open-mpi.org/software/ompi/v1.4/

On Sep 20, 2011, at 1:16 PM, Blosch, Edwin L wrote:

> I'm having trouble building 1.4.3 using PGI 10.9. I searched the list archives briefly but I didn't stumble across anything that looked like the same problem, so I thought I'd ask if an expert might recognize the nature of the problem here.
>
> The configure command:
>
> ./configure --prefix=/release/openmpi-pgi --without-tm --without-sge --enable-mpirun-prefix-by-default --enable-contrib-no-build=vt --enable-mca-no-build=maffinity --disable-per-user-config-files --disable-io-romio --with-mpi-f90-size=small --enable-static --disable-shared --with-wrapper-cflags=-Msignextend --with-wrapper-cxxflags=-Msignextend CXX=/appserv/pgi/linux86-64/10.9/bin/pgCC CC=/appserv/pgi/linux86-64/10.9/bin/pgcc 'CFLAGS= -O2 -Mcache_align -Minfo -Msignextend -Msignextend' 'CXXFLAGS= -O2 -Mcache_align -Minfo -Msignextend -Msignextend' F77=/appserv/pgi/linux86-64/10.9/bin/pgf95 'FFLAGS=-D_GNU_SOURCE -O2 -Mcache_align -Minfo -Munixlogical' FC=/appserv/pgi/linux86-64/10.9/bin/pgf95 'FCFLAGS=-D_GNU_SOURCE -O2 -Mcache_align -Minfo -Munixlogical' 'LDFLAGS= -Bstatic_pgi'
>
> The place where the build eventually dies:
>
> /bin/sh ../../../libtool --tag=CXX --mode=link /appserv/pgi/linux86-64/10.9/bin/pgCC -DNDEBUG -O2 -Mcache_align -Minfo -Msignextend -Msignextend -version-info 0:1:0 -export-dynamic -Bstatic_pgi -o libmpi_cxx.la -rpath /release/cfd/openmpi-pgi/lib mpicxx.lo intercepts.lo comm.lo datatype.lo win.lo file.lo ../../../ompi/libmpi.la -lnsl -lutil -lpthread
> libtool: link: tpldir=Template.dir
> libtool: link: rm -rf Template.dir
> libtool: link: /appserv/pgi/linux86-64/10.9/bin/pgCC --prelink_objects --instantiation_dir Template.dir mpicxx.o intercepts.o comm.o datatype.o win.o file.o
> pgCC-Warning-prelink_objects switch is deprecated
> pgCC-Warning-instantiation_dir switch is deprecated
> /usr/lib64/crt1.o: In function `_start':
> /usr/src/packages/BUILD/glibc-2.9/csu/../sysdeps/x86_64/elf/start.S:109: undefined reference to `main'
> mpicxx.o: In function `__sti___9_mpicxx_cc_a6befbec':
> (.text+0x49): undefined reference to `ompi_mpi_errors_are_fatal'
> mpicxx.o: In function `__sti___9_mpicxx_cc_a6befbec':
> (.text+0x62): undefined reference to `ompi_mpi_errors_return'
> mpicxx.o: In function `__sti___9_mpicxx_cc_a6befbec':
> (.text+0x7b): undefined reference to `ompi_mpi_errors_throw_exceptions'
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Jeff Squyres
jsquyres_at_[hidden]
For corporate legal information go to:
http://www.cisco.com/web/about/doing_business/legal/cri/